aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-18 10:50:45 -0400
committerMike Frysinger <vapier@gentoo.org>2015-08-20 10:38:40 -0400
commitd6fcdb53ed7341f25db859516fa0383fca95eb1d (patch)
treef83cd35d71b71852a7cac12bd1b45fb2c7db1d10 /configure.ac
parentsecurity: lock down privs a bit via prctl (diff)
downloadpax-utils-d6fcdb53ed7341f25db859516fa0383fca95eb1d.tar.gz
pax-utils-d6fcdb53ed7341f25db859516fa0383fca95eb1d.tar.bz2
pax-utils-d6fcdb53ed7341f25db859516fa0383fca95eb1d.zip
security: use seccomp to lock ourselves downv1.1
This has a minor speed hit (a few milliseconds), but otherwise provides a decent balance.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c3591ff..327d9b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,13 @@ AS_IF([test "x$with_caps" = "xyes"], [
AC_ARG_WITH([python], [AS_HELP_STRING([--with-python], [use lddtree.py])])
AM_CONDITIONAL([USE_PYTHON], [test "x$with_python" = "xyes"])
+AC_ARG_WITH([seccomp], [AS_HELP_STRING([--with-seccomp], [build with seccomp])])
+AS_IF([test "x$with_seccomp" = "xyes"], [
+ PKG_CHECK_MODULES(LIBSECCOMP, libseccomp)
+ CPPFLAGS="$CPPFLAGS $LIBSECCOMP_CFLAGS -DWANT_SECCOMP"
+ LIBS="$LIBS $LIBSECCOMP_LIBS"
+])
+
AX_CFLAGS_WARN_ALL
AC_DEFUN([PT_CHECK_CFLAG],[AX_CHECK_COMPILER_FLAGS([$1],[CFLAGS="$CFLAGS $1"])])
m4_foreach_w([flag], [