summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2012-03-27 16:39:50 +1300
committerKent Fredric <kentfredric@gmail.com>2012-03-27 16:39:50 +1300
commit21f0e64c25193586e72e796980f14806a2a90885 (patch)
tree8baf312e8df117663c711243daef82f011557069 /dev-perl/B-Hooks-OP-Check-EntersubForCV/B-Hooks-OP-Check-EntersubForCV-0.90.0.ebuild
parent[newversion] Audio-SndFile-0.90.0 (diff)
downloadperl-overlay-21f0e64c25193586e72e796980f14806a2a90885.tar.gz
perl-overlay-21f0e64c25193586e72e796980f14806a2a90885.tar.bz2
perl-overlay-21f0e64c25193586e72e796980f14806a2a90885.zip
[newversion] B-Hooks-OP-Check-EntersubForCV-0.90.0
(Portage version: 2.2.0_alpha95/git/Linux x86_64, signed Manifest commit with key 4132B87441EA24A4EB5E6DE181EC638ED7AE97A6)
Diffstat (limited to 'dev-perl/B-Hooks-OP-Check-EntersubForCV/B-Hooks-OP-Check-EntersubForCV-0.90.0.ebuild')
-rw-r--r--dev-perl/B-Hooks-OP-Check-EntersubForCV/B-Hooks-OP-Check-EntersubForCV-0.90.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/B-Hooks-OP-Check-EntersubForCV/B-Hooks-OP-Check-EntersubForCV-0.90.0.ebuild b/dev-perl/B-Hooks-OP-Check-EntersubForCV/B-Hooks-OP-Check-EntersubForCV-0.90.0.ebuild
new file mode 100644
index 000000000..ac40893bd
--- /dev/null
+++ b/dev-perl/B-Hooks-OP-Check-EntersubForCV/B-Hooks-OP-Check-EntersubForCV-0.90.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI=4
+MODULE_AUTHOR=ZEFRAM
+MODULE_VERSION=0.09
+inherit perl-module
+
+DESCRIPTION='Invoke callbacks on construction of entersub OPs for certain CVs'
+LICENSE=" || ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+perl_meta_configure() {
+ # B::Hooks::OP::Check 0.19 ( 0.190.0 )
+ echo \>=dev-perl/B-Hooks-OP-Check-0.190.0
+ # B::Utils 0.19 ( 0.190.0 )
+ echo \>=dev-perl/B-Utils-0.190.0
+ # ExtUtils::Depends
+ echo dev-perl/extutils-depends
+ # ExtUtils::MakeMaker 6.42 ( 6.420.0 )
+ echo \>=virtual/perl-ExtUtils-MakeMaker-6.42
+}
+perl_meta_build() {
+ # B::Hooks::OP::Check 0.19 ( 0.190.0 )
+ echo \>=dev-perl/B-Hooks-OP-Check-0.190.0
+ # B::Utils 0.19 ( 0.190.0 )
+ echo \>=dev-perl/B-Utils-0.190.0
+ # ExtUtils::MakeMaker 6.42 ( 6.420.0 )
+ echo \>=virtual/perl-ExtUtils-MakeMaker-6.42
+}
+perl_meta_runtime() {
+ # B::Hooks::OP::Check 0.19 ( 0.190.0 )
+ echo \>=dev-perl/B-Hooks-OP-Check-0.190.0
+ # B::Utils 0.19 ( 0.190.0 )
+ echo \>=dev-perl/B-Utils-0.190.0
+ # Scalar::Util
+ echo virtual/perl-Scalar-List-Utils
+ # parent
+ echo virtual/perl-parent
+}
+DEPEND="
+ $(perl_meta_configure)
+ $(perl_meta_build)
+ $(perl_meta_runtime)
+"
+RDEPEND="
+ $(perl_meta_runtime)
+"
+SRC_TEST="do"