summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Denisov <pavel.a.denisov@gmail.com>2014-06-21 14:13:06 +0400
committerKent Fredric <kentfredric@gmail.com>2014-06-27 12:10:05 +1200
commit1eff9e935b7ef94185b0112fd90f6156f7212bfd (patch)
tree5db462e85f85e90156e195aa67eb5b0fc19ed609 /dev-perl/Dancer-Plugin-Database-Core/Dancer-Plugin-Database-Core-0.60.0.ebuild
parent[ebuild] Fixed CGI-Struct, JSON-MaybeXS which had a $(extra_conflicts) more (diff)
downloadperl-overlay-1eff9e935b7ef94185b0112fd90f6156f7212bfd.tar.gz
perl-overlay-1eff9e935b7ef94185b0112fd90f6156f7212bfd.tar.bz2
perl-overlay-1eff9e935b7ef94185b0112fd90f6156f7212bfd.zip
[added] dev-perl/Dancer-Plugin-Database-Core-0.60.0
Package-Manager: portage-2.2.10
Diffstat (limited to 'dev-perl/Dancer-Plugin-Database-Core/Dancer-Plugin-Database-Core-0.60.0.ebuild')
-rw-r--r--dev-perl/Dancer-Plugin-Database-Core/Dancer-Plugin-Database-Core-0.60.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Dancer-Plugin-Database-Core/Dancer-Plugin-Database-Core-0.60.0.ebuild b/dev-perl/Dancer-Plugin-Database-Core/Dancer-Plugin-Database-Core-0.60.0.ebuild
new file mode 100644
index 000000000..24a4d6fc0
--- /dev/null
+++ b/dev-perl/Dancer-Plugin-Database-Core/Dancer-Plugin-Database-Core-0.60.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI=5
+MODULE_AUTHOR=AMBS
+MODULE_VERSION=0.06
+MODULE_SECTION="Dancer"
+inherit perl-module
+
+DESCRIPTION='Shared core for D1 and D2 Database plugins'
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+perl_meta_configure() {
+ # ExtUtils::MakeMaker
+ echo virtual/perl-ExtUtils-MakeMaker
+}
+perl_meta_build() {
+ # Test::More
+ echo virtual/perl-Test-Simple
+}
+perl_meta_runtime() {
+ # DBI
+ echo dev-perl/DBI
+ # perl 5.006 ( 5.6.0 )
+ echo \>=dev-lang/perl-5.6.0
+}
+DEPEND="
+ $(perl_meta_configure)
+ $(perl_meta_build)
+ $(perl_meta_runtime)
+"
+RDEPEND="
+ $(perl_meta_runtime)
+"
+SRC_TEST="do parallel"