summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/perl/perl-5.10.1-r9.ebuild')
-rw-r--r--dev-lang/perl/perl-5.10.1-r9.ebuild19
1 files changed, 18 insertions, 1 deletions
diff --git a/dev-lang/perl/perl-5.10.1-r9.ebuild b/dev-lang/perl/perl-5.10.1-r9.ebuild
index 9570d1050..3a5d4bb66 100644
--- a/dev-lang/perl/perl-5.10.1-r9.ebuild
+++ b/dev-lang/perl/perl-5.10.1-r9.ebuild
@@ -84,13 +84,27 @@ pkg_setup() {
LIBPERL="libperl$(get_libname ${MY_PV})"
if use ithreads ; then
+ ewarn "THREADS WARNING:"
ewarn "PLEASE NOTE: You are compiling ${MY_P} with"
ewarn "interpreter-level threading enabled."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
+ echo
epause 5
fi
+ if has_version dev-lang/perl ; then
+ if ( use ithreads && ! built_with_use dev-lang/perl ithreads ) || \
+ ( ! use ithreads && built_with_use dev-lang/perl ithreads ) || \
+ ( use debug && ! built_with_use dev-lang/perl debug ) || \
+ ( ! use debug && built_with_use dev-lang/perl debug ) ; then
+ ewarn "TOGGLED USE-FLAGS WARNING:"
+ ewarn "You changed one of the use-flags ithreads or debug."
+ ewarn "You must rebuild all perl-modules installed."
+ ewarn "Use: perl-cleaner --???"
+ epause
+ fi
+ fi
if ${IS_PERL} && [[ ! -f "${ROOT}/usr/$(get_libdir)/${LIBPERL}" ]] ; then
# Make sure we have libperl installed ...
@@ -147,7 +161,7 @@ src_configure() {
cat <<-EOF > "${S}/ext/Compress-Raw-Zlib/config.in"
BUILD_ZLIB = False
INCLUDE = /usr/include
- LIB = /usr/{get_libdir}
+ LIB = /usr/$(get_libdir)
OLD_ZLIB = False
GZIP_OS_CODE = AUTO_DETECT
@@ -173,6 +187,9 @@ src_configure() {
myarch=${CHOST}
myarch="${myarch%%-*}-${osname}"
fi
+ if use debug ; then
+ myarch="${myarch}-debug"
+ fi
# allow either gdbm to provide ndbm (in <gdbm/ndbm.h>) or db1