aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gmail.com>2024-01-25 12:49:27 -0800
committerArthur Zamarin <arthurzam@gentoo.org>2024-01-27 19:04:43 +0200
commit49a5f82f19951e1aeed6b47418bd1e220d64f6fe (patch)
tree94fe278e5e9bcfd90fbc9a69c4ad9a8626e04a42
parentpyproject: bump dependencies (diff)
downloadpkgcheck-49a5f82f19951e1aeed6b47418bd1e220d64f6fe.tar.gz
pkgcheck-49a5f82f19951e1aeed6b47418bd1e220d64f6fe.tar.bz2
pkgcheck-49a5f82f19951e1aeed6b47418bd1e220d64f6fe.zip
docs: Add intersphinx linkages
For any references that go back into those, they're not reachable for doc rendering without this. Signed-off-by: Brian Harring <ferringb@gmail.com> Closes: https://github.com/pkgcore/pkgcheck/pull/658 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--doc/conf.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/doc/conf.py b/doc/conf.py
index 84aae9ea..b89bd7bd 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -324,3 +324,13 @@ epub_exclude_files = ["search.html"]
# If false, no index is generated.
# epub_use_index = True
+
+intersphinx_mapping = {
+ "python": ("https://docs.python.org/3", None),
+ "chardet": ("https://chardet.readthedocs.io/en/latest", None),
+ "lazy-object-proxy": ("https://python-lazy-object-proxy.readthedocs.io/en/latest", None),
+ "setuptools": ("https://setuptools.pypa.io/en/latest", None),
+}
+intersphinx_mapping.update(
+ (x, (f"https://pkgcore.github.io/{x}", None)) for x in ("pkgcore snakeoil").split()
+)