aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-01-19 11:42:55 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-01-19 11:42:55 +0200
commit831d540429ca82532703e4efa4fd99e7d68d5d98 (patch)
tree4c3f9f9f09949d04b404c3a1c12910c8cd3ee144
parentci: test py3.13 (diff)
downloadpkgcheck-831d540429ca82532703e4efa4fd99e7d68d5d98.tar.gz
pkgcheck-831d540429ca82532703e4efa4fd99e7d68d5d98.tar.bz2
pkgcheck-831d540429ca82532703e4efa4fd99e7d68d5d98.zip
update python versions in various places
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--LICENSE2
-rw-r--r--README.rst6
-rw-r--r--pyproject.toml2
-rw-r--r--tox.ini2
4 files changed, 6 insertions, 6 deletions
diff --git a/LICENSE b/LICENSE
index efadf0d1..2d60dd3d 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,4 +1,4 @@
-Copyright (c) 2006-2021, pkgcheck contributors
+Copyright (c) 2006-2024, pkgcheck contributors
All rights reserved.
Redistribution and use in source and binary forms, with or without
diff --git a/README.rst b/README.rst
index 251b5796..1c78f9a1 100644
--- a/README.rst
+++ b/README.rst
@@ -59,9 +59,9 @@ functionality for purposes such as CI or VCS commit support.
Tests
=====
-A standalone test runner is integrated in setup.py; to run, just execute::
+Normal pytest is used, just execute::
- python setup.py test
+ pytest
In addition, a tox config is provided so the testsuite can be run in a
virtualenv setup against all supported python versions. To run tests for all
@@ -69,7 +69,7 @@ environments just execute **tox** in the root directory of a repo or unpacked
tarball. Otherwise, for a specific python version execute something similar to
the following::
- tox -e py39
+ tox -e py311
.. _pkgcore: https://github.com/pkgcore/pkgcore
diff --git a/pyproject.toml b/pyproject.toml
index 71bfe200..a2f2531e 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -28,9 +28,9 @@ maintainers = [
]
classifiers = [
"License :: OSI Approved :: BSD License",
- "Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
"Programming Language :: Python :: 3.11",
+ "Programming Language :: Python :: 3.12",
]
dynamic = ["version"]
diff --git a/tox.ini b/tox.ini
index ec97ccc5..d71b88ce 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py3{9,10,11,12}
+envlist = py3{10,11,12}
skip_missing_interpreters = True
isolated_build = True