summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile5
-rw-r--r--tox.ini4
2 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 1c9d813..5168496 100644
--- a/Makefile
+++ b/Makefile
@@ -8,10 +8,9 @@ SPHINXPROJ = GentooPolicyGuide
SOURCEDIR = .
BUILDDIR = _build
-html:
- @$(SPHINXBUILD) -M $@ "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
+all: html
-.PHONY: html Makefile
+.PHONY: all Makefile
# Catch-all target: route all unknown targets to Sphinx using the new
# "make mode" option. $(O) is meant as a shortcut for $(SPHINXOPTS).
diff --git a/tox.ini b/tox.ini
index 5913c11..1873355 100644
--- a/tox.ini
+++ b/tox.ini
@@ -5,6 +5,8 @@ skipsdist = True
[testenv]
deps =
sphinx
+whitelist_externals =
+ make
commands =
- make html
+ make {posargs:html}