summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-20 11:47:45 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-20 11:47:45 +0000
commit199228d412c83e00f0c4af7ba34f166a891b4e87 (patch)
tree8aba71db4ea0e3b6539eccaf1dc0fd9e3920fca1 /bin/repoman
parentSupport print() function with Python 2 in some files. (diff)
downloadportage-idfetch-199228d412c83e00f0c4af7ba34f166a891b4e87.tar.gz
portage-idfetch-199228d412c83e00f0c4af7ba34f166a891b4e87.tar.bz2
portage-idfetch-199228d412c83e00f0c4af7ba34f166a891b4e87.zip
Update syntax of numbers for compatibility with Python 3.
(2to3-3.1 -f numliterals -nw ${FILES}) svn path=/main/trunk/; revision=14292
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman6
1 files changed, 3 insertions, 3 deletions
diff --git a/bin/repoman b/bin/repoman
index 2f0068cc..c849a22f 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -82,7 +82,7 @@ disallowed_filename_chars_re = re.compile(r'[^a-zA-Z0-9._\-+:]')
bad = create_color_func("BAD")
# A sane umask is needed for files that portage creates.
-os.umask(022)
+os.umask(0o22)
repoman_settings = portage.config(local_config=False,
config_incrementals=portage.const.INCREMENTALS)
repoman_settings.lock()
@@ -940,7 +940,7 @@ for x in scanlist:
pkgs = {}
for y in checkdirlist:
if y in no_exec and \
- stat.S_IMODE(os.stat(os.path.join(checkdir, y)).st_mode) & 0111:
+ stat.S_IMODE(os.stat(os.path.join(checkdir, y)).st_mode) & 0o111:
stats["file.executable"] += 1
fails["file.executable"].append(os.path.join(checkdir, y))
if y.endswith(".ebuild"):
@@ -1219,7 +1219,7 @@ for x in scanlist:
stats['changelog.ebuildadded'] += 1
fails['changelog.ebuildadded'].append(relative_path)
- if stat.S_IMODE(os.stat(full_path).st_mode) & 0111:
+ if stat.S_IMODE(os.stat(full_path).st_mode) & 0o111:
stats["file.executable"] += 1
fails["file.executable"].append(x+"/"+y+".ebuild")
if vcs in ("cvs", "svn") and check_ebuild_notadded and y not in eadded: