summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-30 22:18:46 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-30 22:18:46 +0000
commit727d18bcfcb0dfa3910b85a18f23940b1efce74a (patch)
tree7e0682567b314c4e4f026e888319febbe3a7ea4b /bin/repoman
parentBug #230245 - Use os.path.basename() on paths returned from `svn list` (diff)
downloadportage-idfetch-727d18bcfcb0dfa3910b85a18f23940b1efce74a.tar.gz
portage-idfetch-727d18bcfcb0dfa3910b85a18f23940b1efce74a.tar.bz2
portage-idfetch-727d18bcfcb0dfa3910b85a18f23940b1efce74a.zip
Bug #230249 - Disable the "ebuild.notadded" check when not in commit mode and
running `svn list` and `svn status` calls in every package dir will be too expensive. svn path=/main/trunk/; revision=10860
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman10
1 files changed, 8 insertions, 2 deletions
diff --git a/bin/repoman b/bin/repoman
index b0c44ddb..febe30a7 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -771,6 +771,12 @@ arch_caches={}
arch_xmatch_caches = {}
shared_xmatch_caches = {"cp-list":{}}
+# Disable the "ebuild.notadded" check when not in commit mode and
+# running `svn list` and `svn status` calls in every package dir
+# will be too expensive.
+enable_ebuild_notadded = not \
+ (vcs == "svn" and repolevel < 3 and options.mode != "commit")
+
for x in scanlist:
#ebuilds and digests added to cvs respectively.
logging.info("checking package %s" % x)
@@ -867,7 +873,7 @@ for x in scanlist:
if not os.path.isdir(os.path.join(checkdir, "files")):
has_filesdir = False
- if vcs:
+ if vcs and check_ebuild_notadded:
try:
if vcs == "cvs":
myf=open(checkdir+"/CVS/Entries","r")
@@ -1070,7 +1076,7 @@ for x in scanlist:
if stat.S_IMODE(os.stat(full_path).st_mode) & 0111:
stats["file.executable"] += 1
fails["file.executable"].append(x+"/"+y+".ebuild")
- if vcs and y not in eadded:
+ if vcs and check_ebuild_notadded and y not in eadded:
#ebuild not added to vcs
stats["ebuild.notadded"]=stats["ebuild.notadded"]+1
fails["ebuild.notadded"].append(x+"/"+y+".ebuild")