summaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-06-15 10:53:36 -0700
committerZac Medico <zmedico@gentoo.org>2010-06-15 10:53:36 -0700
commit04cdd7c9ecb92caacada00d78d80a9b159d7390c (patch)
tree870b1f5459d88ab8eb5f50ccf21090e86bf4418c /bin
parentmake.conf(5): document LDFLAGS with a warning, explain the different between ... (diff)
downloadportage-multirepo-04cdd7c9ecb92caacada00d78d80a9b159d7390c.tar.gz
portage-multirepo-04cdd7c9ecb92caacada00d78d80a9b159d7390c.tar.bz2
portage-multirepo-04cdd7c9ecb92caacada00d78d80a9b159d7390c.zip
Bug #324075 - Avoid erroneous 'Invalid Gentoo Copyright' warnings when
the vcs (git) does not support mtime preservation. Also, fix the same check to work for ebuilds wiht copyrigh beginning in 2011 and later.
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman5
1 files changed, 5 insertions, 0 deletions
diff --git a/bin/repoman b/bin/repoman
index 14d442dc..6124f040 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -494,6 +494,9 @@ elif os.path.isdir(os.path.join(portdir_overlay, ".hg")):
# This is needed because we try to avoid merge collisions.
check_changelog = vcs in ('CVS', 'SVN')
+# Disable copyright/mtime check if vcs does not preserve mtime (bug #324075).
+check_copyright_mtime = vcs not in ('git',)
+
vcs_local_opts = repoman_settings.get("REPOMAN_VCS_LOCAL_OPTS", "").split()
vcs_global_opts = repoman_settings.get("REPOMAN_VCS_GLOBAL_OPTS")
if vcs_global_opts is None:
@@ -1769,6 +1772,8 @@ for x in scanlist:
# Syntax Checks
relative_path = os.path.join(x, y + ".ebuild")
full_path = os.path.join(repodir, relative_path)
+ if not check_copyright_mtime:
+ pkg.mtime = None
try:
# All ebuilds should have utf_8 encoding.
f = codecs.open(_unicode_encode(full_path,