aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-04-27 10:32:05 +0200
committerFabian Groffen <grobian@gentoo.org>2019-04-27 10:32:05 +0200
commitf5e47a9148cdd26eaddca435d3f313c8ffbd1946 (patch)
tree7527595964765940f4a95a695237223a0d2c6f7c
parentTODO: qdepends supports correct SLOT matching now (diff)
downloadportage-utils-f5e47a9148cdd26eaddca435d3f313c8ffbd1946.tar.gz
portage-utils-f5e47a9148cdd26eaddca435d3f313c8ffbd1946.tar.bz2
portage-utils-f5e47a9148cdd26eaddca435d3f313c8ffbd1946.zip
buildsys: don't install q-reinit script anymore
flat caches were removed, so were the options to generate them, no need to call and fail Thanks Kent Fredric Closes: https://bugs.gentoo.org/684468 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--Makefile.am5
-rw-r--r--Makefile.in129
-rw-r--r--repo.postsync/q-reinit10
3 files changed, 43 insertions, 101 deletions
diff --git a/Makefile.am b/Makefile.am
index a70f9aa4..93060194 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,11 +7,6 @@ SUBDIRS = \
tests \
$(NULL)
-portagedir = $(sysconfdir)/portage
-postsyncddir = $(portagedir)/repo.postsync.d
-
-dist_postsyncd_SCRIPTS = repo.postsync/q-reinit
-
APPLETS = \
q \
qatom \
diff --git a/Makefile.in b/Makefile.in
index 7866e93a..b211bddb 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -14,7 +14,6 @@
@SET_MAKE@
-
VPATH = @srcdir@
am__is_gnu_make = { \
if test -z '$(MAKELEVEL)'; then \
@@ -237,16 +236,14 @@ am__aclocal_m4_deps = $(top_srcdir)/autotools/m4/00gnulib.m4 \
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
DIST_COMMON = $(srcdir)/Makefile.am $(top_srcdir)/configure \
- $(am__configure_deps) $(dist_postsyncd_SCRIPTS) \
- $(am__DIST_COMMON)
+ $(am__configure_deps) $(am__DIST_COMMON)
am__CONFIG_DISTCLEAN_FILES = config.status config.cache config.log \
configure.lineno config.status.lineno
mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = config.h
CONFIG_CLEAN_FILES =
CONFIG_CLEAN_VPATH_FILES =
-am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(postsyncddir)" \
- "$(DESTDIR)$(man1dir)"
+am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)"
PROGRAMS = $(bin_PROGRAMS)
am_q_OBJECTS = q-main.$(OBJEXT) q-q.$(OBJEXT) q-qatom.$(OBJEXT) \
q-qcache.$(OBJEXT) q-qcheck.$(OBJEXT) q-qdepends.$(OBJEXT) \
@@ -263,34 +260,6 @@ AM_V_lt = $(am__v_lt_@AM_V@)
am__v_lt_ = $(am__v_lt_@AM_DEFAULT_V@)
am__v_lt_0 = --silent
am__v_lt_1 =
-am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
-am__vpath_adj = case $$p in \
- $(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
- *) f=$$p;; \
- esac;
-am__strip_dir = f=`echo $$p | sed -e 's|^.*/||'`;
-am__install_max = 40
-am__nobase_strip_setup = \
- srcdirstrip=`echo "$(srcdir)" | sed 's/[].[^$$\\*|]/\\\\&/g'`
-am__nobase_strip = \
- for p in $$list; do echo "$$p"; done | sed -e "s|$$srcdirstrip/||"
-am__nobase_list = $(am__nobase_strip_setup); \
- for p in $$list; do echo "$$p $$p"; done | \
- sed "s| $$srcdirstrip/| |;"' / .*\//!s/ .*/ ./; s,\( .*\)/[^/]*$$,\1,' | \
- $(AWK) 'BEGIN { files["."] = "" } { files[$$2] = files[$$2] " " $$1; \
- if (++n[$$2] == $(am__install_max)) \
- { print $$2, files[$$2]; n[$$2] = 0; files[$$2] = "" } } \
- END { for (dir in files) print dir, files[dir] }'
-am__base_list = \
- sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
- sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
-am__uninstall_files_from_dir = { \
- test -z "$$files" \
- || { test ! -d "$$dir" && test ! -f "$$dir" && test ! -r "$$dir"; } \
- || { echo " ( cd '$$dir' && rm -f" $$files ")"; \
- $(am__cd) "$$dir" && rm -f $$files; }; \
- }
-SCRIPTS = $(dist_postsyncd_SCRIPTS)
AM_V_P = $(am__v_P_@AM_V@)
am__v_P_ = $(am__v_P_@AM_DEFAULT_V@)
am__v_P_0 = false
@@ -340,6 +309,33 @@ am__can_run_installinfo = \
n|no|NO) false;; \
*) (install-info --version) >/dev/null 2>&1;; \
esac
+am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
+am__vpath_adj = case $$p in \
+ $(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
+ *) f=$$p;; \
+ esac;
+am__strip_dir = f=`echo $$p | sed -e 's|^.*/||'`;
+am__install_max = 40
+am__nobase_strip_setup = \
+ srcdirstrip=`echo "$(srcdir)" | sed 's/[].[^$$\\*|]/\\\\&/g'`
+am__nobase_strip = \
+ for p in $$list; do echo "$$p"; done | sed -e "s|$$srcdirstrip/||"
+am__nobase_list = $(am__nobase_strip_setup); \
+ for p in $$list; do echo "$$p $$p"; done | \
+ sed "s| $$srcdirstrip/| |;"' / .*\//!s/ .*/ ./; s,\( .*\)/[^/]*$$,\1,' | \
+ $(AWK) 'BEGIN { files["."] = "" } { files[$$2] = files[$$2] " " $$1; \
+ if (++n[$$2] == $(am__install_max)) \
+ { print $$2, files[$$2]; n[$$2] = 0; files[$$2] = "" } } \
+ END { for (dir in files) print dir, files[dir] }'
+am__base_list = \
+ sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
+ sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
+am__uninstall_files_from_dir = { \
+ test -z "$$files" \
+ || { test ! -d "$$dir" && test ! -f "$$dir" && test ! -r "$$dir"; } \
+ || { echo " ( cd '$$dir' && rm -f" $$files ")"; \
+ $(am__cd) "$$dir" && rm -f $$files; }; \
+ }
man1dir = $(mandir)/man1
NROFF = nroff
MANS = $(dist_man_MANS)
@@ -1551,9 +1547,6 @@ SUBDIRS = \
tests \
$(NULL)
-portagedir = $(sysconfdir)/portage
-postsyncddir = $(portagedir)/repo.postsync.d
-dist_postsyncd_SCRIPTS = repo.postsync/q-reinit
APPLETS = \
q \
qatom \
@@ -1741,41 +1734,6 @@ clean-binPROGRAMS:
q$(EXEEXT): $(q_OBJECTS) $(q_DEPENDENCIES) $(EXTRA_q_DEPENDENCIES)
@rm -f q$(EXEEXT)
$(AM_V_CCLD)$(LINK) $(q_OBJECTS) $(q_LDADD) $(LIBS)
-install-dist_postsyncdSCRIPTS: $(dist_postsyncd_SCRIPTS)
- @$(NORMAL_INSTALL)
- @list='$(dist_postsyncd_SCRIPTS)'; test -n "$(postsyncddir)" || list=; \
- if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(postsyncddir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(postsyncddir)" || exit 1; \
- fi; \
- for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- if test -f "$$d$$p"; then echo "$$d$$p"; echo "$$p"; else :; fi; \
- done | \
- sed -e 'p;s,.*/,,;n' \
- -e 'h;s|.*|.|' \
- -e 'p;x;s,.*/,,;$(transform)' | sed 'N;N;N;s,\n, ,g' | \
- $(AWK) 'BEGIN { files["."] = ""; dirs["."] = 1; } \
- { d=$$3; if (dirs[d] != 1) { print "d", d; dirs[d] = 1 } \
- if ($$2 == $$4) { files[d] = files[d] " " $$1; \
- if (++n[d] == $(am__install_max)) { \
- print "f", d, files[d]; n[d] = 0; files[d] = "" } } \
- else { print "f", d "/" $$4, $$1 } } \
- END { for (d in files) print "f", d, files[d] }' | \
- while read type dir files; do \
- if test "$$dir" = .; then dir=; else dir=/$$dir; fi; \
- test -z "$$files" || { \
- echo " $(INSTALL_SCRIPT) $$files '$(DESTDIR)$(postsyncddir)$$dir'"; \
- $(INSTALL_SCRIPT) $$files "$(DESTDIR)$(postsyncddir)$$dir" || exit $$?; \
- } \
- ; done
-
-uninstall-dist_postsyncdSCRIPTS:
- @$(NORMAL_UNINSTALL)
- @list='$(dist_postsyncd_SCRIPTS)'; test -n "$(postsyncddir)" || exit 0; \
- files=`for p in $$list; do echo "$$p"; done | \
- sed -e 's,.*/,,;$(transform)'`; \
- dir='$(DESTDIR)$(postsyncddir)'; $(am__uninstall_files_from_dir)
mostlyclean-compile:
-rm -f *.$(OBJEXT)
@@ -2422,10 +2380,10 @@ distcleancheck: distclean
exit 1; } >&2
check-am: all-am
check: check-recursive
-all-am: Makefile $(PROGRAMS) $(SCRIPTS) $(MANS) config.h
+all-am: Makefile $(PROGRAMS) $(MANS) config.h
installdirs: installdirs-recursive
installdirs-am:
- for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(postsyncddir)" "$(DESTDIR)$(man1dir)"; do \
+ for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)"; do \
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done
install: install-recursive
@@ -2482,7 +2440,7 @@ info: info-recursive
info-am:
-install-data-am: install-dist_postsyncdSCRIPTS install-man
+install-data-am: install-man
install-dvi: install-dvi-recursive
@@ -2531,8 +2489,7 @@ ps: ps-recursive
ps-am:
-uninstall-am: uninstall-binPROGRAMS uninstall-dist_postsyncdSCRIPTS \
- uninstall-man
+uninstall-am: uninstall-binPROGRAMS uninstall-man
uninstall-man: uninstall-man1
@@ -2548,16 +2505,16 @@ uninstall-man: uninstall-man1
distclean-hdr distclean-libtool distclean-tags distcleancheck \
distdir distuninstallcheck dvi dvi-am html html-am info \
info-am install install-am install-binPROGRAMS install-data \
- install-data-am install-dist_postsyncdSCRIPTS install-dvi \
- install-dvi-am install-exec install-exec-am install-exec-hook \
- install-html install-html-am install-info install-info-am \
- install-man install-man1 install-pdf install-pdf-am install-ps \
- install-ps-am install-strip installcheck installcheck-am \
- installdirs installdirs-am maintainer-clean \
- maintainer-clean-generic mostlyclean mostlyclean-compile \
- mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \
- tags tags-am uninstall uninstall-am uninstall-binPROGRAMS \
- uninstall-dist_postsyncdSCRIPTS uninstall-man uninstall-man1
+ install-data-am install-dvi install-dvi-am install-exec \
+ install-exec-am install-exec-hook install-html install-html-am \
+ install-info install-info-am install-man install-man1 \
+ install-pdf install-pdf-am install-ps install-ps-am \
+ install-strip installcheck installcheck-am installdirs \
+ installdirs-am maintainer-clean maintainer-clean-generic \
+ mostlyclean mostlyclean-compile mostlyclean-generic \
+ mostlyclean-libtool pdf pdf-am ps ps-am tags tags-am uninstall \
+ uninstall-am uninstall-binPROGRAMS uninstall-man \
+ uninstall-man1
.PRECIOUS: Makefile
diff --git a/repo.postsync/q-reinit b/repo.postsync/q-reinit
deleted file mode 100644
index 0833c66f..00000000
--- a/repo.postsync/q-reinit
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-
-repository_name=$1
-repository_path=$3
-
-if [ -n "${repository_name}" ]; then
- q ${PORTAGE_QUIET:+-q} --reinitialize="${repository_path}"
-fi
-
-: