aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-03-09 19:55:47 +0100
committerFabian Groffen <grobian@gentoo.org>2019-03-09 19:58:23 +0100
commitaffdba842a41c49b71911109272186acf36cfd8a (patch)
treed204e4b684260ae6759e06aeb99a96fa3d64a0dd /Makefile.am
parentrmspace: add copyright (diff)
downloadportage-utils-affdba842a41c49b71911109272186acf36cfd8a.tar.gz
portage-utils-affdba842a41c49b71911109272186acf36cfd8a.tar.bz2
portage-utils-affdba842a41c49b71911109272186acf36cfd8a.zip
libq: introduce set to replace virtuals (queue)
The virtuals file contained some queue functions which actually were list functions. Replaced this with a proper set, which hash backend to speed up many search operations. Changed throughout the code to use more efficient path. While at it, merge xstrdup wrappers in xmalloc, and use wrappers more consistently. Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index db20879..2e6f985 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -119,16 +119,15 @@ EXTRA_DIST += \
libq/rmspace.c \
libq/safe_io.c \
libq/scandirat.c \
+ libq/set.c \
libq/vdb.c \
libq/vdb_get_next_dir.c \
- libq/virtuals.c \
libq/xarray.c \
libq/xasprintf.c \
libq/xchdir.c \
libq/xmalloc.c \
libq/xmkdir.c \
libq/xregex.c \
- libq/xstrdup.c \
libq/xsystem.c \
main.c \
main.h \