aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-11-27 00:04:57 -0500
committerMike Frysinger <vapier@gentoo.org>2016-11-27 00:04:57 -0500
commit4c9a3b2f82783e7a97c4503778aadb1d2b06e14b (patch)
tree2a5f98e2cac517bf223881dc334c319163ac5095 /Makefile
parentautotools: update source list (diff)
downloadportage-utils-4c9a3b2f82783e7a97c4503778aadb1d2b06e14b.tar.gz
portage-utils-4c9a3b2f82783e7a97c4503778aadb1d2b06e14b.tar.bz2
portage-utils-4c9a3b2f82783e7a97c4503778aadb1d2b06e14b.zip
build: add lazy support for STATIC=yes builds
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index baa27c2..949b375 100644
--- a/Makefile
+++ b/Makefile
@@ -22,7 +22,8 @@ CPPFLAGS ?=
CPPFLAGS += -DENABLE_NLS=$(call istrue,$(NLS))
DBG_CFLAGS = -O0 -DEBUG -g3 -ggdb -fno-pie $(call check_gcc, -fsanitize=address -fsanitize=leak -fsanitize=undefined)
#CFLAGS += -Os -DOPTIMIZE_FOR_SIZE=2 -falign-functions=2 -falign-jumps=2 -falign-labels=2 -falign-loops=2
-#LDFLAGS := -pie
+LDFLAGS_static_1 = -static
+LDFLAGS += $(LDFLAGS_static_$(call istrue,$(STATIC)))
LIBADD += $(shell echo | $(CC) -dM -E - | grep -q ' __FreeBSD__' && echo '-lkvm')
LIBADD += -liniparser
DESTDIR :=