aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-02-18 07:31:33 +0000
committerMike Frysinger <vapier@gentoo.org>2014-02-18 07:31:33 +0000
commit53eb581c73a37cee5dbff7dd36f6c47379d97c02 (patch)
treec55c9dfba6117a450ddf7b58c8eca6832b9a964f /Makefile
parentqcache: mark everything static (diff)
downloadportage-utils-53eb581c73a37cee5dbff7dd36f6c47379d97c02.tar.gz
portage-utils-53eb581c73a37cee5dbff7dd36f6c47379d97c02.tar.bz2
portage-utils-53eb581c73a37cee5dbff7dd36f6c47379d97c02.zip
build with -Wold-style-definition to weed out old bad func definitions
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 717352d..bda2deb 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Copyright 2005-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-projects/portage-utils/Makefile,v 1.76 2013/09/29 22:12:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-projects/portage-utils/Makefile,v 1.77 2014/02/18 07:31:33 vapier Exp $
####################################################################
check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
@@ -13,7 +13,8 @@ WFLAGS := -Wall -Wunused -Wimplicit -Wshadow -Wformat=2 \
-Wchar-subscripts -Wcast-align -Wno-format-nonliteral \
$(call check_gcc, -Wsequence-point) \
$(call check_gcc, -Wextra) \
- $(call check_gcc, -Wno-sign-compare)
+ $(call check_gcc, -Wno-sign-compare) \
+ $(call check_gcc, -Wold-style-definition)
CFLAGS ?= -O2 -g -pipe
CFLAGS += -std=gnu99