aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2006-01-28 20:41:45 +0000
committerNed Ludd <solar@gentoo.org>2006-01-28 20:41:45 +0000
commitb208effcc188c8c772a3d273de7dcf3156b35738 (patch)
tree65623196959feb7455b30b7f9127da887e08f997 /Makefile
parentdefine stub functions for now since the weak handling is broken when building... (diff)
downloadportage-utils-b208effcc188c8c772a3d273de7dcf3156b35738.tar.gz
portage-utils-b208effcc188c8c772a3d273de7dcf3156b35738.tar.bz2
portage-utils-b208effcc188c8c772a3d273de7dcf3156b35738.zip
- update the way manpages are created when exit code from help2man & applet does not return 0; Enable qmerge applet by default but force env variable to control getting into its guts
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 572c8f6..40f0a58 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Copyright 2005-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-projects/portage-utils/Makefile,v 1.43 2006/01/25 04:03:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-projects/portage-utils/Makefile,v 1.44 2006/01/28 20:41:45 solar Exp $
####################################################################
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
@@ -46,7 +46,7 @@ HFLAGS += -DVERSION=\"$(PV)\"
endif
#####################################################
-APPLETS := $(shell sed -n '/^DECLARE_APPLET/s:.*(\(.*\))$$:\1:p' applets.h)
+APPLETS := $(shell sed -n '/^DECLARE_APPLET/s:.*(\(.*\))$$:\1:p' applets.h|sort)
SRC := $(APPLETS:%=%.c) main.c
MPAGES := man/q.1
HFLAGS += $(foreach a,$(APPLETS),-DAPPLET_$a)