aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'libq/Makefile.am')
-rw-r--r--libq/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/libq/Makefile.am b/libq/Makefile.am
index 9cb19a2..da100b6 100644
--- a/libq/Makefile.am
+++ b/libq/Makefile.am
@@ -9,10 +9,8 @@ QFILES = \
dep.c dep.h \
eat_file.c eat_file.h \
hash.c hash.h \
- hash_fd.c hash_fd.h \
human_readable.c human_readable.h \
i18n.h \
- md5_sha1_sum.c md5_sha1_sum.h \
prelink.c prelink.h \
profile.c profile.h \
rmspace.c rmspace.h \
@@ -29,6 +27,12 @@ QFILES = \
xsystem.c xsystem.h \
$(NULL)
+if !QMANIFEST_ENABLED
+if !QTEGRITY_ENABLED
+QFILES += hash_md5_sha1.c hash_md5_sha1.h
+endif
+endif
+
noinst_LTLIBRARIES = libq.la
libq_la_SOURCES = $(QFILES)
libq_la_CPPFLAGS = \