aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-25 08:29:05 +0000
committerSam James <sam@gentoo.org>2024-02-25 08:29:43 +0000
commit8832264b4e5bff768346ba5a6d2f828dcf468c60 (patch)
treef1eb4fc53d68a83893f03654dfe2858f8fcd8b1b
parenttest_baseline: Improve robustness with cleanup (diff)
downloadportage-8832264b4e5bff768346ba5a6d2f828dcf468c60.tar.gz
portage-8832264b4e5bff768346ba5a6d2f828dcf468c60.tar.bz2
portage-8832264b4e5bff768346ba5a6d2f828dcf468c60.zip
NEWS, meson.build: prepare for portage-3.0.63portage-3.0.63
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--NEWS30
-rw-r--r--meson.build2
2 files changed, 30 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 83be37204..eb84651b5 100644
--- a/NEWS
+++ b/NEWS
@@ -6,7 +6,7 @@ Release notes take the form of the following optional categories:
* Bug fixes
* Cleanups
-portage-3.0.63 (UNRELEASED)
+portage-3.0.63 (2024-02-25)
--------------
Bug fixes:
@@ -14,6 +14,34 @@ Bug fixes:
* bin/install-qa-check.d: 90gcc-warnings: drop warnings with too many FPs (bug #925460).
+* AsyncioEventLoop: Call process.run_exitfuncs() before close (bug #925240).
+
+ Fixes hang with FEATURES="network-sandbox-proxy" or FEATURES="distcc".
+
+* SchedulerInterface/PollScheduler: Add _loop property (bug #925333).
+
+ Fixes erroneous assert.
+
+* _dynamic_deps_preload: Fix settings reference (bug #925350).
+
+ Fix KeyError with --dynamic-deps.
+
+* process.spawn: Fix logic for missing libc.unshare on musl (bug #925311).
+
+ Fix handling when we can't unshare where we might e.g. modify the hostname
+ of the real system on musl.
+
+* dbapi: Fix TypeError when passing Exception to warnings.warn (bug #922935).
+
+ Fix testUpdateDbentryDbapiTestCase.
+
+* _start_proc: Prevent premature ForkProcess garbage collection (bug #925456).
+
+ Fix warnings/errors like "[ERROR] Task was destroyed but it is pending!".
+
+Cleanups:
+* More asyncio porting.
+
portage-3.0.62 (2024-02-22)
--------------
diff --git a/meson.build b/meson.build
index aeb3f93e6..e826f6ffa 100644
--- a/meson.build
+++ b/meson.build
@@ -1,7 +1,7 @@
project(
'portage',
'c',
- version : '3.0.62',
+ version : '3.0.63',
license : 'GPL-2.0-or-later',
meson_version : '>=0.58.0'
)