summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorheracles <heracles@localhost>2007-04-24 00:13:00 +0000
committerheracles <heracles@localhost>2007-04-24 00:13:00 +0000
commitb6eaf54a914424fd46cb5fe9dca15eb68aee3bca (patch)
tree3b9e28fcb231fd3eba100f5df5a45397ce140751 /app-admin
parentdev-db/postgresql-libs: RESTRICT=test (diff)
downloadexperimental-b6eaf54a914424fd46cb5fe9dca15eb68aee3bca.tar.gz
experimental-b6eaf54a914424fd46cb5fe9dca15eb68aee3bca.tar.bz2
experimental-b6eaf54a914424fd46cb5fe9dca15eb68aee3bca.zip
moved blocker and cruft removal code to eselect-postgresql
svn path=/experimental/; revision=254
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect-postgresql/Manifest8
-rw-r--r--app-admin/eselect-postgresql/eselect-postgresql-0.1.ebuild32
2 files changed, 35 insertions, 5 deletions
diff --git a/app-admin/eselect-postgresql/Manifest b/app-admin/eselect-postgresql/Manifest
index 1fadd95..be9d2a6 100644
--- a/app-admin/eselect-postgresql/Manifest
+++ b/app-admin/eselect-postgresql/Manifest
@@ -6,10 +6,10 @@ AUX postgresql.eselect 7674 RMD160 e966c299cf5a8dbff844033c8c0350ce9d57ed72 SHA1
MD5 28488970887e22444199327bf091bdf6 files/postgresql.eselect 7674
RMD160 e966c299cf5a8dbff844033c8c0350ce9d57ed72 files/postgresql.eselect 7674
SHA256 25b4f19ad909b74f69a02da2482cfb7f529c74bf4b92b3b4536fe6aab701fca8 files/postgresql.eselect 7674
-EBUILD eselect-postgresql-0.1.ebuild 779 RMD160 b47732afd4fed53579a6ef81011e427d3f1041e5 SHA1 3bdecb1eeab12c3814b20850a8f6517d0abc021e SHA256 c7e95b54d36722cddaa1c1a0b3fa88d889d6d173c981eeb89f841e911f0e6d4d
-MD5 06b3f44c51bea131888766c94b35f49a eselect-postgresql-0.1.ebuild 779
-RMD160 b47732afd4fed53579a6ef81011e427d3f1041e5 eselect-postgresql-0.1.ebuild 779
-SHA256 c7e95b54d36722cddaa1c1a0b3fa88d889d6d173c981eeb89f841e911f0e6d4d eselect-postgresql-0.1.ebuild 779
+EBUILD eselect-postgresql-0.1.ebuild 1449 RMD160 d5380e32102d907cb761b329b3a4ca83dcb6dd57 SHA1 2de0220975229e8d972b35916182f5532758c693 SHA256 befbba09c754e4edc8a374fe1641781918030de8164f1ada666b6756ead732bd
+MD5 aa6b6a4a06abf7dd6707bebbefa0f36f eselect-postgresql-0.1.ebuild 1449
+RMD160 d5380e32102d907cb761b329b3a4ca83dcb6dd57 eselect-postgresql-0.1.ebuild 1449
+SHA256 befbba09c754e4edc8a374fe1641781918030de8164f1ada666b6756ead732bd eselect-postgresql-0.1.ebuild 1449
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-eselect-postgresql-0.1 0
RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 files/digest-eselect-postgresql-0.1 0
SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855 files/digest-eselect-postgresql-0.1 0
diff --git a/app-admin/eselect-postgresql/eselect-postgresql-0.1.ebuild b/app-admin/eselect-postgresql/eselect-postgresql-0.1.ebuild
index e767885..9a66eac 100644
--- a/app-admin/eselect-postgresql/eselect-postgresql-0.1.ebuild
+++ b/app-admin/eselect-postgresql/eselect-postgresql-0.1.ebuild
@@ -13,7 +13,10 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE=""
-RDEPEND="app-admin/eselect"
+RDEPEND="
+ app-admin/eselect
+ !<dev-db/libpq-99.99.99
+ "
src_install() {
keepdir /etc/eselect/postgresql
@@ -26,3 +29,30 @@ src_install() {
dodir /usr/bin
dosym /usr/bin/eselect /usr/bin/postgresql-config
}
+
+pkg_preinst() {
+ local ff=""
+ for f in "${ROOT}"/usr/include/{postgresql,libpq-fe.h,libpq,postgres_ext.h} ; do
+ [[ -e "${f}" ]] || continue
+ [[ -L "${f}" ]] && continue
+ if [[ -d "${f}" ]] ; then
+ if [[ -z "$(find "${f}" -not \( -type l -or -type d \))" ]] ; then
+ rm -rf "${f}"
+ else
+ ff="$ff $f"
+ fi
+ else
+ ff="$ff $f"
+ fi
+ done
+ if [[ ! -z "$ff" ]] ; then
+ eerror "You have leftovers from previous postgresql installations that"
+ eerror "can't be dealt with automatically. The proper way to treat"
+ eerror "files is:"
+ eerror ""
+ eerror "rm -rf ${ff}"
+ eerror ""
+ die "Please, remove the files manually"
+ fi
+}
+