summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-libs/files')
-rw-r--r--dev-db/postgresql-libs/files/digest-postgresql-libs-8.0.146
-rw-r--r--dev-db/postgresql-libs/files/digest-postgresql-libs-8.0.153
-rw-r--r--dev-db/postgresql-libs/files/postgresql-8.0-common.patch76
-rw-r--r--dev-db/postgresql-libs/files/postgresql-8.0-libs.patch2
-rw-r--r--dev-db/postgresql-libs/files/postgresql-8.0-nls.patch25
-rw-r--r--dev-db/postgresql-libs/files/postgresql-8.0-sh-spinlocks.patch36
6 files changed, 80 insertions, 68 deletions
diff --git a/dev-db/postgresql-libs/files/digest-postgresql-libs-8.0.14 b/dev-db/postgresql-libs/files/digest-postgresql-libs-8.0.14
deleted file mode 100644
index ce9aab5..0000000
--- a/dev-db/postgresql-libs/files/digest-postgresql-libs-8.0.14
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 ffaaa630db6613cedbe935edd85d2a98 postgresql-base-8.0.14.tar.bz2 7907547
-RMD160 4e1c627af447ef24ec343baa3121edd2427d9fa9 postgresql-base-8.0.14.tar.bz2 7907547
-SHA256 8201ce5a99051c2b561f4b58ce07f17fe4959383ef38afcb25ab802119f9755e postgresql-base-8.0.14.tar.bz2 7907547
-MD5 6a6feb48ca70bf1e36e99bab1671b66d postgresql-opt-8.0.14.tar.bz2 134706
-RMD160 ff8773b373aa33f6c43f2d7cc3a56b4484197fc7 postgresql-opt-8.0.14.tar.bz2 134706
-SHA256 b097922bb346c039dc605b45927dca2916394d587000d5412b30c9ca5a1c117a postgresql-opt-8.0.14.tar.bz2 134706
diff --git a/dev-db/postgresql-libs/files/digest-postgresql-libs-8.0.15 b/dev-db/postgresql-libs/files/digest-postgresql-libs-8.0.15
new file mode 100644
index 0000000..e7881b8
--- /dev/null
+++ b/dev-db/postgresql-libs/files/digest-postgresql-libs-8.0.15
@@ -0,0 +1,3 @@
+MD5 3ee548b3643e0a0a4b76493e81b336f3 postgresql-8.0.15.tar.bz2 11253897
+RMD160 6aff5c63dce73eea609f0b6e013cd043ae8b7a37 postgresql-8.0.15.tar.bz2 11253897
+SHA256 59408a00db1c73e638a11af10438a827507b7a72b53916d58f2d44c477718714 postgresql-8.0.15.tar.bz2 11253897
diff --git a/dev-db/postgresql-libs/files/postgresql-8.0-common.patch b/dev-db/postgresql-libs/files/postgresql-8.0-common.patch
new file mode 100644
index 0000000..40932ec
--- /dev/null
+++ b/dev-db/postgresql-libs/files/postgresql-8.0-common.patch
@@ -0,0 +1,76 @@
+diff --git a/config/programs.m4 b/config/programs.m4
+index 3f87396..9c7fbf0 100644
+--- a/config/programs.m4
++++ b/config/programs.m4
+@@ -153,13 +153,13 @@ AC_DEFUN([PGAC_CHECK_GETTEXT],
+ dnl FIXME: We should probably check for version >=0.10.36.
+ AC_CHECK_PROGS(XGETTEXT, xgettext)
+
+- # Note: share/locale is always the default, independent of $datadir
+- localedir='${prefix}/share/locale'
+- if test x"$prefix" = x"NONE"; then
+- exp_localedir="$ac_default_prefix/share/locale"
+- else
+- exp_localedir="$prefix/share/locale"
+- fi
++ # Note: share/locale *WAS* always the default, independent of $datadir
++ AC_ARG_WITH([locale-dir],
++ AC_HELP_STRING([--with-locale-dir],[Set path to locale files]),
++ [ localedir="${withval}" ],
++ [ localedir='${prefix}/share/locale' ]
++ )
++ exp_localedir="${localedir}"
+
+ AC_SUBST(localedir)
+ AC_DEFINE_UNQUOTED(LOCALEDIR, ["$exp_localedir"],
+diff --git a/configure.in b/configure.in
+index c71b175..674036a 100644
+--- a/configure.in
++++ b/configure.in
+@@ -19,10 +19,6 @@ m4_pattern_forbid(^PGAC_)dnl to catch undefined macros
+
+ AC_INIT([PostgreSQL], [8.0.15], [pgsql-bugs@postgresql.org])
+
+-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.53], [], [m4_fatal([Autoconf version 2.59 is required.
+-Untested combinations of 'autoconf' and PostgreSQL versions are not
+-recommended. You can remove the check from 'configure.in' but it is then
+-your responsibility whether the result works or not.])])
+ AC_COPYRIGHT([Copyright (c) 1996-2005, PostgreSQL Global Development Group])
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
+ AC_CONFIG_AUX_DIR(config)
+diff --git a/src/include/storage/s_lock.h b/src/include/storage/s_lock.h
+index 0c2dff0..d548d4d 100644
+--- a/src/include/storage/s_lock.h
++++ b/src/include/storage/s_lock.h
+@@ -239,6 +239,31 @@ tas(volatile slock_t *lock)
+ #endif /* __s390__ || __s390x__ */
+
+
++#if defined(__sh__)
++#define HAS_TEST_AND_SET
++
++typedef unsigned char slock_t;
++
++#define TAS(lock) tas(lock)
++
++static __inline__ int
++tas(volatile slock_t *lock)
++{
++ register int _res = 1;
++
++ __asm__ __volatile__(
++ "tas.b @%1\n\t"
++ "movt %0\n\t"
++ "xor #1,%0"
++: "=z"(_res)
++: "r"(lock)
++: "t","memory");
++ return _res;
++}
++
++#endif /* __sh__ */
++
++
+ #if defined(__sparc__)
+ #define HAS_TEST_AND_SET
+
diff --git a/dev-db/postgresql-libs/files/postgresql-8.0-libs.patch b/dev-db/postgresql-libs/files/postgresql-8.0-libs.patch
index fa4cc70..ba9ed64 100644
--- a/dev-db/postgresql-libs/files/postgresql-8.0-libs.patch
+++ b/dev-db/postgresql-libs/files/postgresql-8.0-libs.patch
@@ -53,7 +53,7 @@ index 2bbdc8e..79aabf1 100644
ifneq ($(PORTNAME), cygwin)
ifneq ($(PORTNAME), win32)
-@@ -104,8 +104,7 @@ # Parallel make trickery
+@@ -104,8 +104,7 @@ $(SUBSYSOBJS): $(DIRS:%=%-recursive) ;
.PHONY: $(DIRS:%=%-recursive)
# Update the commonly used headers before building the subdirectories
diff --git a/dev-db/postgresql-libs/files/postgresql-8.0-nls.patch b/dev-db/postgresql-libs/files/postgresql-8.0-nls.patch
deleted file mode 100644
index dabc966..0000000
--- a/dev-db/postgresql-libs/files/postgresql-8.0-nls.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/config/programs.m4 b/config/programs.m4
-index 3f87396..9c7fbf0 100644
---- a/config/programs.m4
-+++ b/config/programs.m4
-@@ -153,13 +153,13 @@ AC_DEFUN([PGAC_CHECK_GETTEXT],
- dnl FIXME: We should probably check for version >=0.10.36.
- AC_CHECK_PROGS(XGETTEXT, xgettext)
-
-- # Note: share/locale is always the default, independent of $datadir
-- localedir='${prefix}/share/locale'
-- if test x"$prefix" = x"NONE"; then
-- exp_localedir="$ac_default_prefix/share/locale"
-- else
-- exp_localedir="$prefix/share/locale"
-- fi
-+ # Note: share/locale *WAS* always the default, independent of $datadir
-+ AC_ARG_WITH([locale-dir],
-+ AC_HELP_STRING([--with-locale-dir],[Set path to locale files]),
-+ [ localedir="${withval}" ],
-+ [ localedir='${prefix}/share/locale' ]
-+ )
-+ exp_localedir="${localedir}"
-
- AC_SUBST(localedir)
- AC_DEFINE_UNQUOTED(LOCALEDIR, ["$exp_localedir"],
diff --git a/dev-db/postgresql-libs/files/postgresql-8.0-sh-spinlocks.patch b/dev-db/postgresql-libs/files/postgresql-8.0-sh-spinlocks.patch
deleted file mode 100644
index 9856f38..0000000
--- a/dev-db/postgresql-libs/files/postgresql-8.0-sh-spinlocks.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git a/src/include/storage/s_lock.h b/src/include/storage/s_lock.h
-index 0c2dff0..d548d4d 100644
---- a/src/include/storage/s_lock.h
-+++ b/src/include/storage/s_lock.h
-@@ -239,6 +239,31 @@ tas(volatile slock_t *lock)
- #endif /* __s390__ || __s390x__ */
-
-
-+#if defined(__sh__)
-+#define HAS_TEST_AND_SET
-+
-+typedef unsigned char slock_t;
-+
-+#define TAS(lock) tas(lock)
-+
-+static __inline__ int
-+tas(volatile slock_t *lock)
-+{
-+ register int _res = 1;
-+
-+ __asm__ __volatile__(
-+ "tas.b @%1\n\t"
-+ "movt %0\n\t"
-+ "xor #1,%0"
-+: "=z"(_res)
-+: "r"(lock)
-+: "t","memory");
-+ return _res;
-+}
-+
-+#endif /* __sh__ */
-+
-+
- #if defined(__sparc__)
- #define HAS_TEST_AND_SET
-