summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-07-22 22:10:59 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-07-22 22:10:59 +0000
commit156041301e185fbb2a7aae083d8ffb27ee5b082a (patch)
tree6b0b8d8ce0e023ed4c948eb846228adf6543215c /dev-db/pgadmin3/pgadmin3-1.4.3.ebuild
downloadtesting-156041301e185fbb2a7aae083d8ffb27ee5b082a.tar.gz
testing-156041301e185fbb2a7aae083d8ffb27ee5b082a.tar.bz2
testing-156041301e185fbb2a7aae083d8ffb27ee5b082a.zip
dev-db/pgadmin3: Version bump to 1.4.3
New debug USE flag added ebuild cleanup svn path=/testing/; revision=3
Diffstat (limited to 'dev-db/pgadmin3/pgadmin3-1.4.3.ebuild')
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.4.3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-db/pgadmin3/pgadmin3-1.4.3.ebuild b/dev-db/pgadmin3/pgadmin3-1.4.3.ebuild
new file mode 100644
index 0000000..1af9a07
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.4.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit wxwidgets eutils
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL"
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/pgadmin3/release/v${PV}/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~x86"
+IUSE="debug"
+
+RESTRICT="mirror"
+
+DEPEND="=x11-libs/wxGTK-2.6*
+ >=dev-db/libpq-7.4
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! built_with_use '=x11-libs/wxGTK-2.6.0' unicode ; then
+ die "${PN} requires wxGTK emerged with USE=\"unicode\""
+ fi
+
+ export WX_GTK_VER=2.6
+ export WX_HOME=/usr
+ need-wxwidgets unicode
+}
+
+
+src_compile() {
+ # pgadmin3 inserts WX_HOME before the WX_CONFIG path below, so we have to strip "/usr" from it
+ econf \
+ --with-wx-config=${WX_CONFIG/\/usr} \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ insinto /usr/share/pixmaps
+ newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm
+
+ insinto /usr/share/pgadmin3
+ newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm
+
+ insinto /usr/share/applications
+ doins "${S}/pkg/pgadmin3.desktop"
+}