summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCHTEKK <CHTEKK@localhost>2006-07-24 13:43:16 +0000
committerCHTEKK <CHTEKK@localhost>2006-07-24 13:43:16 +0000
commit3e95d668f78a9972b2f83fe19b16de4f3e4dd22f (patch)
tree8e9822251d75c01aa30c9d7443dcc3abbbd175cd /dev-db/pgadmin3/pgadmin3-1.4.3.ebuild
parentdev-libs/libpqxx: Update KEYWORDS. Add missing cd "${S}". Fix typo in src_tes... (diff)
downloadtesting-3e95d668f78a9972b2f83fe19b16de4f3e4dd22f.tar.gz
testing-3e95d668f78a9972b2f83fe19b16de4f3e4dd22f.tar.bz2
testing-3e95d668f78a9972b2f83fe19b16de4f3e4dd22f.zip
dev-db/pgadmin3: Fix KEYWORDS. Update style. Delete RESTRICT="mirror", the license permits redistribution. Delete unicode USE flag check, that USE flag is unavailable in wxGTK 2.6.
svn path=/testing/; revision=20
Diffstat (limited to 'dev-db/pgadmin3/pgadmin3-1.4.3.ebuild')
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.4.3.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/dev-db/pgadmin3/pgadmin3-1.4.3.ebuild b/dev-db/pgadmin3/pgadmin3-1.4.3.ebuild
index 1af9a07..0c07b5f 100644
--- a/dev-db/pgadmin3/pgadmin3-1.4.3.ebuild
+++ b/dev-db/pgadmin3/pgadmin3-1.4.3.ebuild
@@ -4,34 +4,27 @@
inherit wxwidgets eutils
-DESCRIPTION="wxWidgets GUI for PostgreSQL"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
HOMEPAGE="http://www.pgadmin.org/"
SRC_URI="mirror://postgresql/pgadmin3/release/v${PV}/src/${P}.tar.gz"
-
SLOT="0"
LICENSE="Artistic"
-KEYWORDS="~x86"
IUSE="debug"
-RESTRICT="mirror"
-
DEPEND="=x11-libs/wxGTK-2.6*
- >=dev-db/libpq-7.4
- >=dev-libs/libxml2-2.5
- >=dev-libs/libxslt-1.1"
+ >=dev-db/libpq-7.4
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/libxslt-1.1"
RDEPEND="${DEPEND}"
pkg_setup() {
- if ! built_with_use '=x11-libs/wxGTK-2.6.0' unicode ; then
- die "${PN} requires wxGTK emerged with USE=\"unicode\""
- fi
-
export WX_GTK_VER=2.6
export WX_HOME=/usr
need-wxwidgets unicode
}
-
src_compile() {
# pgadmin3 inserts WX_HOME before the WX_CONFIG path below, so we have to strip "/usr" from it
econf \