summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-08-06 21:48:24 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-08-06 21:48:24 +0000
commit8a837cb7aa3a1587f6b55bdf5c488113d0bf6916 (patch)
tree3d5996b4900b93b50e0490b20163271acb177d83 /dev-db/pgadmin3/pgadmin3-1.4.3.ebuild
parentdev-libs/libpqxx: Add cd S, instead of specifying it later. (diff)
downloadtesting-8a837cb7aa3a1587f6b55bdf5c488113d0bf6916.tar.gz
testing-8a837cb7aa3a1587f6b55bdf5c488113d0bf6916.tar.bz2
testing-8a837cb7aa3a1587f6b55bdf5c488113d0bf6916.zip
dev-db/pgadmin3: Patching out --debug=yes/no specification for wx_config which would need debug USE-flag on wxGTK if debug USE-flag set for pgadmin3
svn path=/testing/; revision=76
Diffstat (limited to 'dev-db/pgadmin3/pgadmin3-1.4.3.ebuild')
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.4.3.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/dev-db/pgadmin3/pgadmin3-1.4.3.ebuild b/dev-db/pgadmin3/pgadmin3-1.4.3.ebuild
index 9b885e0..8d7664e 100644
--- a/dev-db/pgadmin3/pgadmin3-1.4.3.ebuild
+++ b/dev-db/pgadmin3/pgadmin3-1.4.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit wxwidgets eutils
+inherit wxwidgets eutils autotools
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
@@ -25,6 +25,19 @@ pkg_setup() {
need-wxwidgets unicode
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # --debug=yes/no for wx_config is only needed if wxGTK debug and
+ # release versions are installed aside. Which is not possible
+ # on Gentoo at the moment.
+ sed -i \
+ -e 's/--debug=[yesno]* //g' \
+ acinclude.m4 || die "sed failed"
+ eautoreconf
+}
+
src_compile() {
cd "${S}"