summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorjohnjay <johnjay@localhost>2006-08-14 18:54:57 +0000
committerjohnjay <johnjay@localhost>2006-08-14 18:54:57 +0000
commit4f83b43f4ceb4dd686a485b2f2821b93d1303232 (patch)
treeac182e27558098d0d1d6c4fcc659e926901fae44 /dev-db
parentdev-db/pgadmin3: Patching out --debug=yes/no specification for wx_config whic... (diff)
downloadtesting-4f83b43f4ceb4dd686a485b2f2821b93d1303232.tar.gz
testing-4f83b43f4ceb4dd686a485b2f2821b93d1303232.tar.bz2
testing-4f83b43f4ceb4dd686a485b2f2821b93d1303232.zip
dev-db/slony1: Adding slony1 1.2.0 RC3
svn path=/testing/; revision=78
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/slony1/files/digest-slony1-1.2.0_rc33
-rw-r--r--dev-db/slony1/files/slony1.conf11
-rwxr-xr-xdev-db/slony1/files/slony1.init37
-rw-r--r--dev-db/slony1/slony1-1.2.0_rc3.ebuild55
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-db/slony1/files/digest-slony1-1.2.0_rc3 b/dev-db/slony1/files/digest-slony1-1.2.0_rc3
new file mode 100644
index 0000000..44e5486
--- /dev/null
+++ b/dev-db/slony1/files/digest-slony1-1.2.0_rc3
@@ -0,0 +1,3 @@
+MD5 92a26e2c4b9122135a81bb34dd31ece4 slony1-1.2.0_rc3.tar.bz2 782067
+RMD160 d0e0f15f48e2ff7bd54253c9f6e68913b3948860 slony1-1.2.0_rc3.tar.bz2 782067
+SHA256 36b3468609f1cb43eec0081acc573ce33d00e642f264ae97dde75d703d15e8c7 slony1-1.2.0_rc3.tar.bz2 782067
diff --git a/dev-db/slony1/files/slony1.conf b/dev-db/slony1/files/slony1.conf
new file mode 100644
index 0000000..8c82b1c
--- /dev/null
+++ b/dev-db/slony1/files/slony1.conf
@@ -0,0 +1,11 @@
+# /etc/conf.d/slony1:
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/files/slony1.conf,v 1.1 2005/05/11 21:34:23 nakano Exp $
+
+# Configuration file for /etc/init.d/slony1
+
+USER=postgres
+DBUSER=postgres
+CLUSTER=your_cluster_name
+DBNAME=your_database_name
+LOGFILE=/var/lib/postgresql/data/slony1.log
+LOGLEVEL=1 # 1(minimum)..4(maximum)
diff --git a/dev-db/slony1/files/slony1.init b/dev-db/slony1/files/slony1.init
new file mode 100755
index 0000000..b6bb3d3
--- /dev/null
+++ b/dev-db/slony1/files/slony1.init
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/files/slony1.init,v 1.1 2005/05/11 21:34:23 nakano Exp $
+
+depend() {
+ need postgresql
+}
+
+start() {
+ ebegin "Starting slony1"
+ /usr/bin/slon -p /var/run/slony1.pid -d $LOGLEVEL $CLUSTER "dbname=$DBNAME user=$DBUSER" >> $LOGFILE 2>&1 &
+
+ while :
+ do
+ cnt=$(($cnt + 1))
+ if [ -f "/var/run/slony1.pid" ]; then
+ ret=0
+ break
+ fi
+
+ if [ $cnt -eq 30 ]; then
+ eerror "Please see log file: $LOGFILE"
+ ret=1
+ break
+ fi
+ sleep 1
+ done
+ eend $ret
+}
+
+stop() {
+ ebegin "Stopping slony1"
+ kill `cat /var/run/slony1.pid`
+ eend $?
+}
+
diff --git a/dev-db/slony1/slony1-1.2.0_rc3.ebuild b/dev-db/slony1/slony1-1.2.0_rc3.ebuild
new file mode 100644
index 0000000..1cd2634
--- /dev/null
+++ b/dev-db/slony1/slony1-1.2.0_rc3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+IUSE="perl doc"
+
+MY_P=${P/_/-}
+DESCRIPTION="A replication system for the PostgreSQL Database Management System"
+HOMEPAGE="http://slony.info/"
+SRC_URI="http://pgfoundry.org/frs/download.php/1015/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-db/postgresql
+ perl? ( dev-perl/DBD-Pg )"
+
+RDEPEND="dev-db/postgresql"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${WORKDIR}/${MY_P}
+ local myconf=""
+
+ myconf="${myconf} --with-pgincludedir=/usr/include/postgresql/pgsql"
+ myconf="${myconf} --with-pgincludeserverdir=/usr/include/postgresql/server"
+ myconf="${myconf} $(use_with perl perltools)"
+ myconf="${myconf} $(use_with doc docs)"
+
+ econf ${myconf} || die
+ emake || die
+
+ if use perl ; then
+ cd ${S}/tools
+ emake || die
+ fi
+ emake || die
+ emake DESTDIR=${D} install || die
+}
+
+src_install() {
+ if useq doc; then
+ dodoc HISTORY-1.1 INSTALL README SAMPLE TODO UPGRADING doc/howto/*.txt
+ dohtml doc/howto/*.html
+ fi
+
+ newinitd ${FILESDIR}/slony1.init slony1 || die
+ newconfd ${FILESDIR}/slony1.conf slony1 || die
+}