summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/libpq/files/libpq-8.0.14-gentoo.patch')
-rw-r--r--dev-db/libpq/files/libpq-8.0.14-gentoo.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-db/libpq/files/libpq-8.0.14-gentoo.patch b/dev-db/libpq/files/libpq-8.0.14-gentoo.patch
new file mode 100644
index 0000000..e6a3700
--- /dev/null
+++ b/dev-db/libpq/files/libpq-8.0.14-gentoo.patch
@@ -0,0 +1,47 @@
+diff -Nru postgresql-8.0.9.orig/src/interfaces/libpq/Makefile postgresql-8.0.9/src/interfaces/libpq/Makefile
+--- postgresql-8.0.9.orig/src/interfaces/libpq/Makefile 2006-11-05 13:20:26.000000000 +0100
++++ postgresql-8.0.9/src/interfaces/libpq/Makefile 2006-11-05 13:24:34.000000000 +0100
+@@ -20,6 +20,8 @@
+ SO_MINOR_VERSION= 0
+ DLTYPE= library
+
++NAME_STATIC_LIB= $(NAME)-$(SO_MAJOR_VERSION)
++
+ override CPPFLAGS := -DFRONTEND -I$(srcdir) $(CPPFLAGS) -I$(top_builddir)/src/port
+ override CFLAGS += $(PTHREAD_CFLAGS)
+
+@@ -136,7 +138,7 @@
+ $(INSTALL_DATA) $(srcdir)/libpq-fe.h $(DESTDIR)$(includedir)
+ $(INSTALL_DATA) $(srcdir)/libpq-int.h $(DESTDIR)$(includedir_internal)
+ $(INSTALL_DATA) $(srcdir)/pqexpbuffer.h $(DESTDIR)$(includedir_internal)
+- $(INSTALL_DATA) $(srcdir)/pg_service.conf.sample $(DESTDIR)$(datadir)/pg_service.conf.sample
++ $(INSTALL_DATA) $(srcdir)/pg_service.conf.sample $(DESTDIR)$(datadir)/pg_service-$(SO_MAJOR_VERSION).conf.sample
+
+ installdirs:
+ $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir) $(DESTDIR)$(includedir_internal)
+diff -Nru postgresql-8.0.9.orig/src/interfaces/libpq/nls.mk postgresql-8.0.9/src/interfaces/libpq/nls.mk
+--- postgresql-8.0.9.orig/src/interfaces/libpq/nls.mk 2006-11-05 13:20:26.000000000 +0100
++++ postgresql-8.0.9/src/interfaces/libpq/nls.mk 2006-11-05 13:24:34.000000000 +0100
+@@ -1,5 +1,5 @@
+ # $PostgreSQL: pgsql/src/interfaces/libpq/nls.mk,v 1.20 2005/01/14 08:57:06 petere Exp $
+-CATALOG_NAME := libpq
++CATALOG_NAME := libpq-4
+ AVAIL_LANGUAGES := af cs de es fr hr it ko nb pl pt_BR ru sk sl sv tr zh_CN zh_TW
+ GETTEXT_FILES := fe-auth.c fe-connect.c fe-exec.c fe-lobj.c fe-misc.c fe-protocol2.c fe-protocol3.c fe-secure.c
+ GETTEXT_TRIGGERS:= libpq_gettext pqInternalNotice:2
+diff -Nru postgresql-8.0.9.orig/src/Makefile.shlib postgresql-8.0.9/src/Makefile.shlib
+--- postgresql-8.0.9.orig/src/Makefile.shlib 2006-11-05 13:20:26.000000000 +0100
++++ postgresql-8.0.9/src/Makefile.shlib 2006-11-05 13:24:34.000000000 +0100
+@@ -360,10 +360,10 @@
+ install-lib: install-lib-static install-lib-shared
+
+ install-lib-static: lib$(NAME).a
+- $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME).a
++ $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME_STATIC_LIB).a
+ ifeq ($(PORTNAME), darwin)
+ cd $(DESTDIR)$(libdir) && \
+- ranlib lib$(NAME).a
++ ranlib lib$(NAME_STATIC_LIB).a
+ endif
+
+ ifeq ($(enable_shared), yes)