summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2020-03-13 15:18:52 +0100
committerSam James <sam@gentoo.org>2023-05-26 07:10:57 +0100
commitf7e808f1460cc895bb136163822181dc28ff39eb (patch)
tree55e3c1620a01d9db6876b4a606edeaee56143c82
parentapp-portage/prefix-toolkit: stack: keepdir /usr/share/aclocal (diff)
downloadprefix-toolkit-9.tar.gz
prefix-toolkit-9.tar.bz2
prefix-toolkit-9.zip
app-portage/prefix-toolkit: startprefix is for Prefix onlyprefix-toolkit-9
To allow for prefix-stack on top of vanilla Gentoo, prefix-stack-setup does make sense there - but startprefix does not. Add comment why prefix-stack does have some RDEPENDs, and reorder RDEPEND to logically match the comment. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Haubenwallner <haubi@gentoo.org> (cherry picked from commit d3088df8d4f537268af659f9910c4600186bbdcc)
-rw-r--r--prefix-toolkit-9.ebuild (renamed from prefix-toolkit-8.ebuild)21
1 files changed, 15 insertions, 6 deletions
diff --git a/prefix-toolkit-8.ebuild b/prefix-toolkit-9.ebuild
index 96f9ee6..05ebbcc 100644
--- a/prefix-toolkit-8.ebuild
+++ b/prefix-toolkit-9.ebuild
@@ -23,17 +23,21 @@ BDEPEND="${DEPEND}
# In prefix-stack, these dependencies actually are the @system set,
# as we rely on the base prefix anyway for package management,
# which should have a proper @system set.
+# Strictly speaking, only baselayout and gcc-config are necessary
+# (and pthreads4w for Winnt), but it is easier for now to install
+# elt-patches, gentoo-functions and gnuconfig as well, instead of
+# fixing all uses that expect them in EPREFIX rather than BROOT.
# See als: pkg_preinst
RDEPEND="${DEPEND}
prefix-stack? (
>=sys-apps/baselayout-prefix-2.6
- sys-apps/gentoo-functions
- app-portage/elt-patches
- sys-devel/gnuconfig
sys-devel/gcc-config
elibc_Winnt? (
dev-libs/pthreads4w
)
+ app-portage/elt-patches
+ sys-apps/gentoo-functions
+ sys-devel/gnuconfig
)
"
@@ -67,7 +71,10 @@ src_unpack() {
else
my_unpack prefix-stack-setup
fi
- my_unpack startprefix
+ if use prefix; then
+ # does not make sense on vanilla Gentoo
+ my_unpack startprefix
+ fi
}
my_prefixify() {
@@ -138,8 +145,10 @@ src_install() {
else
dobin prefix-stack-setup
fi
- exeinto /
- doexe startprefix
+ if use prefix; then
+ exeinto /
+ doexe startprefix
+ fi
}
pkg_preinst() {