summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--patches/01_all_static_library_location.patch4
-rw-r--r--patches/04_all_non-zero_exit_status_on_failure.patch2
-rw-r--r--patches/05_all_loadable_sqlite_extensions.patch2
-rw-r--r--patches/06_all_regenerate_platform-specific_modules.patch6
-rw-r--r--patches/24_all_tests_environment.patch2
-rw-r--r--patches/61_all_process_data.patch6
-rw-r--r--patches/81_all_use_new_readline_function_types__closes__20374_.patch28
-rw-r--r--patches/82_all_new_plan__just_remove_typecasts__closes__20374_.patch37
-rw-r--r--patches/83_all_Issue__20374__Avoid_compiler_warnings_when_compiling_readline_with_libedit_.patch37
9 files changed, 11 insertions, 113 deletions
diff --git a/patches/01_all_static_library_location.patch b/patches/01_all_static_library_location.patch
index 5c9c3ed..ed5757e 100644
--- a/patches/01_all_static_library_location.patch
+++ b/patches/01_all_static_library_location.patch
@@ -4,7 +4,7 @@ http://bugs.python.org/issue6103
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -891,6 +891,19 @@
+@@ -892,6 +892,19 @@
fi; \
else true; \
fi
@@ -24,7 +24,7 @@ http://bugs.python.org/issue6103
# Install the versioned manual page
altmaninstall:
-@@ -1084,18 +1097,6 @@
+@@ -1088,18 +1101,6 @@
else true; \
fi; \
done
diff --git a/patches/04_all_non-zero_exit_status_on_failure.patch b/patches/04_all_non-zero_exit_status_on_failure.patch
index 3346979..e233c29 100644
--- a/patches/04_all_non-zero_exit_status_on_failure.patch
+++ b/patches/04_all_non-zero_exit_status_on_failure.patch
@@ -21,7 +21,7 @@ http://bugs.python.org/issue6731
failed = self.failed[:]
print
print "Failed to build these modules:"
-@@ -2237,6 +2241,7 @@
+@@ -2241,6 +2245,7 @@
'Tools/scripts/2to3',
'Lib/smtpd.py']
)
diff --git a/patches/05_all_loadable_sqlite_extensions.patch b/patches/05_all_loadable_sqlite_extensions.patch
index 8ad2466..c473f95 100644
--- a/patches/05_all_loadable_sqlite_extensions.patch
+++ b/patches/05_all_loadable_sqlite_extensions.patch
@@ -3,7 +3,7 @@ http://bugs.python.org/issue10268
--- configure.ac
+++ configure.ac
-@@ -2317,6 +2317,15 @@
+@@ -2310,6 +2310,15 @@
TCLTK_LIBS="$with_tcltk_libs"
fi
diff --git a/patches/06_all_regenerate_platform-specific_modules.patch b/patches/06_all_regenerate_platform-specific_modules.patch
index d4333f1..cdec0e5 100644
--- a/patches/06_all_regenerate_platform-specific_modules.patch
+++ b/patches/06_all_regenerate_platform-specific_modules.patch
@@ -79,7 +79,7 @@ http://bugs.python.org/issue12619
# Build static library
# avoid long command lines, same as LIBRARY_OBJS
$(LIBRARY): $(LIBRARY_OBJS)
-@@ -958,7 +984,7 @@
+@@ -962,7 +988,7 @@
unittest unittest/test \
lib-old \
curses pydoc_data $(MACHDEPS)
@@ -88,7 +88,7 @@ http://bugs.python.org/issue12619
@for i in $(SCRIPTDIR) $(LIBDEST); \
do \
if test ! -d $(DESTDIR)$$i; then \
-@@ -1041,23 +1067,6 @@
+@@ -1045,23 +1071,6 @@
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
@@ -112,7 +112,7 @@ http://bugs.python.org/issue12619
python-config: $(srcdir)/Misc/python-config.in
# Substitution happens here, as the completely-expanded BINDIR
# is not available in configure
-@@ -1350,7 +1359,7 @@
+@@ -1354,7 +1363,7 @@
Python/thread.o: @THREADHEADERS@
# Declare targets that aren't real files
diff --git a/patches/24_all_tests_environment.patch b/patches/24_all_tests_environment.patch
index 85a4ec3..b00853a 100644
--- a/patches/24_all_tests_environment.patch
+++ b/patches/24_all_tests_environment.patch
@@ -158,7 +158,7 @@ http://bugs.python.org/issue1674555
--- Makefile.pre.in
+++ Makefile.pre.in
-@@ -793,7 +793,7 @@
+@@ -794,7 +794,7 @@
TESTOPTS= -l $(EXTRATESTOPTS)
TESTPROG= $(srcdir)/Lib/test/regrtest.py
diff --git a/patches/61_all_process_data.patch b/patches/61_all_process_data.patch
index 6f02c8a..a7865af 100644
--- a/patches/61_all_process_data.patch
+++ b/patches/61_all_process_data.patch
@@ -85,7 +85,7 @@ python_generate_wrapper_scripts() to check if Python supports GENTOO_PYTHON_TARG
}
--- Python/sysmodule.c
+++ Python/sysmodule.c
-@@ -1560,6 +1560,10 @@
+@@ -1564,6 +1564,10 @@
makeargvobject(int argc, char **argv)
{
PyObject *av;
@@ -96,7 +96,7 @@ python_generate_wrapper_scripts() to check if Python supports GENTOO_PYTHON_TARG
if (argc <= 0 || argv == NULL) {
/* Ensure at least one (empty) argument is seen */
static char *empty_argv[1] = {""};
-@@ -1584,7 +1588,11 @@
+@@ -1588,7 +1592,11 @@
} else
v = PyString_FromString(argv[i]);
#else
@@ -109,7 +109,7 @@ python_generate_wrapper_scripts() to check if Python supports GENTOO_PYTHON_TARG
#endif
if (v == NULL) {
Py_DECREF(av);
-@@ -1612,7 +1620,15 @@
+@@ -1616,7 +1624,15 @@
if (PySys_SetObject("argv", av) != 0)
Py_FatalError("can't assign sys.argv");
if (updatepath && path != NULL) {
diff --git a/patches/81_all_use_new_readline_function_types__closes__20374_.patch b/patches/81_all_use_new_readline_function_types__closes__20374_.patch
deleted file mode 100644
index b63f4c7..0000000
--- a/patches/81_all_use_new_readline_function_types__closes__20374_.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-# HG changeset patch
-# User Benjamin Peterson <benjamin@python.org>
-# Date 1390541532 18000
-# Fri Jan 24 00:32:12 2014 -0500
-# Branch 2.7
-# Node ID 79b82ebc4fd17fda401c32840da1da0577e3c73e
-# Parent f28b60141c5c417111670a22b223f0c411136c7b
-use new readline function types (closes #20374)
-
-diff --git a/Modules/readline.c b/Modules/readline.c
---- a/Modules/readline.c
-+++ b/Modules/readline.c
-@@ -911,12 +911,12 @@
- rl_bind_key_in_map ('\t', rl_complete, emacs_meta_keymap);
- rl_bind_key_in_map ('\033', rl_complete, emacs_meta_keymap);
- /* Set our hook functions */
-- rl_startup_hook = (Function *)on_startup_hook;
-+ rl_startup_hook = (rl_hook_func_t *)on_startup_hook;
- #ifdef HAVE_RL_PRE_INPUT_HOOK
-- rl_pre_input_hook = (Function *)on_pre_input_hook;
-+ rl_pre_input_hook = (rl_hook_func_t *)on_pre_input_hook;
- #endif
- /* Set our completion function */
-- rl_attempted_completion_function = (CPPFunction *)flex_complete;
-+ rl_attempted_completion_function = (rl_completion_func_t *)flex_complete;
- /* Set Python word break characters */
- completer_word_break_characters =
- rl_completer_word_break_characters =
diff --git a/patches/82_all_new_plan__just_remove_typecasts__closes__20374_.patch b/patches/82_all_new_plan__just_remove_typecasts__closes__20374_.patch
deleted file mode 100644
index 71ac4b1..0000000
--- a/patches/82_all_new_plan__just_remove_typecasts__closes__20374_.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-# HG changeset patch
-# User Benjamin Peterson <benjamin@python.org>
-# Date 1390581856 18000
-# Fri Jan 24 11:44:16 2014 -0500
-# Branch 2.7
-# Node ID 5e42e5764ac6277d61c0af231d402f59c223c91a
-# Parent 79b82ebc4fd17fda401c32840da1da0577e3c73e
-new plan: just remove typecasts (closes #20374)
-
-diff --git a/Modules/readline.c b/Modules/readline.c
---- a/Modules/readline.c
-+++ b/Modules/readline.c
-@@ -852,7 +852,7 @@
- * before calling the normal completer */
-
- static char **
--flex_complete(char *text, int start, int end)
-+flex_complete(const char *text, int start, int end)
- {
- #ifdef HAVE_RL_COMPLETION_APPEND_CHARACTER
- rl_completion_append_character ='\0';
-@@ -911,12 +911,12 @@
- rl_bind_key_in_map ('\t', rl_complete, emacs_meta_keymap);
- rl_bind_key_in_map ('\033', rl_complete, emacs_meta_keymap);
- /* Set our hook functions */
-- rl_startup_hook = (rl_hook_func_t *)on_startup_hook;
-+ rl_startup_hook = on_startup_hook;
- #ifdef HAVE_RL_PRE_INPUT_HOOK
-- rl_pre_input_hook = (rl_hook_func_t *)on_pre_input_hook;
-+ rl_pre_input_hook = on_pre_input_hook;
- #endif
- /* Set our completion function */
-- rl_attempted_completion_function = (rl_completion_func_t *)flex_complete;
-+ rl_attempted_completion_function = flex_complete;
- /* Set Python word break characters */
- completer_word_break_characters =
- rl_completer_word_break_characters =
diff --git a/patches/83_all_Issue__20374__Avoid_compiler_warnings_when_compiling_readline_with_libedit_.patch b/patches/83_all_Issue__20374__Avoid_compiler_warnings_when_compiling_readline_with_libedit_.patch
deleted file mode 100644
index 9934b80..0000000
--- a/patches/83_all_Issue__20374__Avoid_compiler_warnings_when_compiling_readline_with_libedit_.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-# HG changeset patch
-# User Ned Deily <nad@acm.org>
-# Date 1391647946 28800
-# Wed Feb 05 16:52:26 2014 -0800
-# Branch 2.7
-# Node ID 0b5b0bfcc7b1dba77ee70ec6abba9037abf93acb
-# Parent 48c5c18110ae810c09b176f4cedf228cc3487451
-Issue #20374: Avoid compiler warnings when compiling readline with libedit.
-
-diff --git a/Modules/readline.c b/Modules/readline.c
---- a/Modules/readline.c
-+++ b/Modules/readline.c
-@@ -749,15 +749,24 @@
- return result;
- }
-
-+
- static int
-+#if defined(_RL_FUNCTION_TYPEDEF)
- on_startup_hook(void)
-+#else
-+on_startup_hook()
-+#endif
- {
- return on_hook(startup_hook);
- }
-
- #ifdef HAVE_RL_PRE_INPUT_HOOK
- static int
-+#if defined(_RL_FUNCTION_TYPEDEF)
- on_pre_input_hook(void)
-+#else
-+on_pre_input_hook()
-+#endif
- {
- return on_hook(pre_input_hook);
- }