aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-06 01:31:13 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-06 01:31:13 +0200
commita59843d9bdbd557d237a4e6f4ec85eabc210d0d9 (patch)
tree745d4e44983f8c4569d02a2ec230b4aa0f095156
parentamd64: use stages-musl config for musl stages (diff)
downloadreleng-a59843d9bdbd557d237a4e6f4ec85eabc210d0d9.tar.gz
releng-a59843d9bdbd557d237a4e6f4ec85eabc210d0d9.tar.bz2
releng-a59843d9bdbd557d237a4e6f4ec85eabc210d0d9.zip
x86: delete obsolete catalyst-auto config file
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--tools/catalyst-auto-x86.conf77
1 files changed, 0 insertions, 77 deletions
diff --git a/tools/catalyst-auto-x86.conf b/tools/catalyst-auto-x86.conf
deleted file mode 100644
index 075bb447..00000000
--- a/tools/catalyst-auto-x86.conf
+++ /dev/null
@@ -1,77 +0,0 @@
-# This is the config file for the catalyst-auto script. It should be pretty
-# self-explanatory.
-
-UPLOAD_USER=x86
-UPLOAD_KEY=/root/.ssh/id_rsa
-host=$(hostname)
-
-ARCH="x86"
-TYPE="auto"
-source /etc/catalyst/release/build.env
-
-SPECS_DIR=${REPO_DIR}/releases/specs/x86
-
-SETS=""
-SPECS="nosuchfile.spec"
-
-KCONFIG_DIR=${REPO_DIR}/releases/kconfig/x86
-
-EXTENSIONS="@(.tar.xz|.tar.bz2|.tar.gz|.tar|.sfs)"
-
-update_symlinks() {
- # Symlink the latest stages3 to build from
- for d in ${BUILD_SRCDIR_BASE}/{default,hardened} ; do
- pushd "${d}" >/dev/null || exit
- shopt -s extglob
- for f in $(ls stage3*${EXTENSIONS} | grep -v latest | give_latest_from_dates ) ; do
- # 20yymmddThhmmssZ
- # 20yymmddhhmmss
- # 20yymmdd
- # 20yy.n
- of=$(perl -p \
- -e 's/20\d{6}T\d{6}Z/latest/g;' \
- -e 's/20\d{6}\d{6}/latest/g;' \
- -e 's/20\d{6}/latest/g;' \
- -e 's/20\d{2}\.\d{2}/latest/g;' \
- <<<"$f")
- ln -svf "$f" "$of"
- done
- popd >/dev/null || exit
- done
-}
-
-post_build() {
- local set=$1 spec=$2
-
- pushd "${BUILD_SRCDIR_BASE}"/default >/dev/null || exit
- UPLOAD_DEST=${BUILD_DESTDIR_BASE}
- case ${spec} in
- stage3.spec)
- upload stage3-i486-${TIMESTAMP}.tar.xz*
- ;;
- installcd-stage2-minimal.spec)
- upload install-x86-minimal-${TIMESTAMP}.iso*
- ;;
- i686/stage3.spec)
- upload stage3-i686-${TIMESTAMP}.tar.xz*
- ;;
- i686/stage3-systemd.spec)
- upload stage3-i686-systemd-${TIMESTAMP}.tar.xz*
- ;;
- esac
- popd >/dev/null || exit
-
- pushd "${BUILD_SRCDIR_BASE}"/hardened >/dev/null || exit
- UPLOAD_DEST=${BUILD_DESTDIR_BASE}/hardened
- case ${spec} in
- hardened/stage3.spec)
- upload stage3-i686-hardened-${TIMESTAMP}.tar.xz*
- ;;
- hardened/admincd-stage2.spec)
- upload admincd-x86-${TIMESTAMP}.iso*
- ;;
- esac
- popd >/dev/null || exit
-}
-
-# vim:ft=sh: