aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-01-08 11:02:26 -0600
committerBen Kohler <bkohler@gentoo.org>2019-01-08 11:02:26 -0600
commita831d3f1499adc4eb04e113fe6a2bf5eef6bd79f (patch)
treef5c39ba7f46e141c654503e8fc8687bc0ee87066
parentsparc/installcd: move from qla-qc-firmware to linux-firmware (diff)
downloadreleng-a831d3f1499adc4eb04e113fe6a2bf5eef6bd79f.tar.gz
releng-a831d3f1499adc4eb04e113fe6a2bf5eef6bd79f.tar.bz2
releng-a831d3f1499adc4eb04e113fe6a2bf5eef6bd79f.zip
catalyst-auto-sparc64.conf: redo post_build modeled after ppc
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--tools/catalyst-auto-sparc64.conf38
1 files changed, 22 insertions, 16 deletions
diff --git a/tools/catalyst-auto-sparc64.conf b/tools/catalyst-auto-sparc64.conf
index 570a0566..3a3e5f0e 100644
--- a/tools/catalyst-auto-sparc64.conf
+++ b/tools/catalyst-auto-sparc64.conf
@@ -46,22 +46,28 @@ update_symlinks() {
done
}
+upload() {
+ rsync -e 'ssh -i /root/.ssh/id_rsa'
+ -a
+ --omit-dir-times
+ --delay-updates
+ "$@"
+ sparc@nightheron.gentoo.org:
+}
post_build() {
- # We only want to do anything on the final (0 argument) post_build call
- [ $# -eq 0 ] || return 0
-
- mkdir -p ${TMPDIR}/empty
- cmd=(
- rsync
- -e 'ssh -i /root/.ssh/id_rsa'
- -a
- --omit-dir-times
- --delay-updates
- )
- "${cmd[@]}" ${TMPDIR}/empty ${DEST}
- "${cmd[@]}" \
- ${BUILD_SRCDIR_BASE}/default/stage3-*${DATESTAMP}*${EXTENSIONS}* \
- ${BUILD_SRCDIR_BASE}/default/*${DATESTAMP}*.iso* \
- sparc@nightheron.gentoo.org:
+ local set=$1 spec=$2
+
+ pushd "${BUILD_SRCDIR_BASE}/default/" > /dev/null
+
+ case ${spec} in
+ stage3.spec
+ upload stage3-*${DATESTAMP}*${EXTENSIONS}*
+ ;;
+ installcd-stage2-minimal.spec
+ upload *${DATESTAMP}*.iso*
+ ;;
+ esac
+
+ popd > /dev/null
}