aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-30 19:01:29 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-30 19:01:29 -0500
commit3d95cec60b1acde2f6561df4dcc26f4b0dffe86c (patch)
tree1cbef270daa57b71a452cdeef4d9d02632db70aa /tools/catalyst-auto-alpha.conf
parenttools: Add UPLOAD_USER variable (diff)
downloadreleng-3d95cec60b1acde2f6561df4dcc26f4b0dffe86c.tar.gz
releng-3d95cec60b1acde2f6561df4dcc26f4b0dffe86c.tar.bz2
releng-3d95cec60b1acde2f6561df4dcc26f4b0dffe86c.zip
tools: Add UPLOAD_KEY
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'tools/catalyst-auto-alpha.conf')
-rw-r--r--tools/catalyst-auto-alpha.conf3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/catalyst-auto-alpha.conf b/tools/catalyst-auto-alpha.conf
index 687d1fc3..a60f979d 100644
--- a/tools/catalyst-auto-alpha.conf
+++ b/tools/catalyst-auto-alpha.conf
@@ -2,6 +2,7 @@
# self-explanatory.
UPLOAD_USER=alpha
+UPLOAD_KEY=/root/.ssh/id_rsa
SPECS_DIR=${REPO_DIR}/releases/specs/alpha
SPECS="stage1.spec stage3.spec"
@@ -34,7 +35,7 @@ update_symlinks() {
upload() {
echo Uploading "$@"
- rsync -e 'ssh -i /root/.ssh/id_rsa -o UserKnownHostsFile=/dev/null -o VerifyHostKeyDNS=yes -o StrictHostKeyChecking=no' "$@" ${UPLOAD_USER}@releng-incoming.gentoo.org:
+ rsync -e 'ssh -i ${UPLOAD_KEY} -o UserKnownHostsFile=/dev/null -o VerifyHostKeyDNS=yes -o StrictHostKeyChecking=no' "$@" ${UPLOAD_USER}@releng-incoming.gentoo.org:
}
post_build() {