aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/ruby/ChangeLog5
-rw-r--r--dev-lang/ruby/Manifest11
-rw-r--r--dev-lang/ruby/ruby-1.9.0.2.ebuild159
-rw-r--r--profiles/package.mask4
4 files changed, 179 insertions, 0 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 93724fa..a169fcb 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.340 2008/07/15 18:07:15 graaff Exp $
+ 23 Jul 2008; Sven Schwyn <schwyn@bitcetera.com> ruby-1.9.0.2.ebuild:
+ New ebuild from #203706 thanks to Senuma Takahiko and Mark Somerville.
+
+*ruby-1.9.0.2 (23 Jul 2008)
+
15 Jul 2008; Hans de Graaff <graaff@gentoo.org> ruby-1.8.6_p230.ebuild:
Drop cjk support since the most recent oniguruma patches no longer apply to
this version, #230111.
diff --git a/dev-lang/ruby/Manifest b/dev-lang/ruby/Manifest
new file mode 100644
index 0000000..00a8222
--- /dev/null
+++ b/dev-lang/ruby/Manifest
@@ -0,0 +1,11 @@
+AUX ruby-1.8.6-memory-leak.diff 1351 RMD160 cba1335fcd52df26b4b2884dea14e0c74852b67a SHA1 184c1743592684abfc1cce8ffa38ae749fe0a1b1 SHA256 90dbc7b444ed936ed8a1fadb443240ec494a6c748d38ff089af423e50bdd9528
+AUX ruby-1.8.6-revert-r15856.patch 3389 RMD160 06cb82094586a1d893b1da5245063bd6f4beb9e1 SHA1 74fa9b4c2485c953ad791516806a75ba70ce5368 SHA256 16394b4e748996ef92419909f49fc59aa5938f76691eb5d7188b056d2b725efc
+DIST onigd2_5_9.tar.gz 221355 RMD160 ceeee9a0221d431d6576a566621ba9badab6423d SHA1 41ca5b916ae1d3b1675fcc45181a0ed04e8726b7 SHA256 b24df7c0fa6fc72ce37fd1e203f378359f29f739a3f4c5b6bdd40ca5f7d25db0
+DIST ruby-1.8.6-p230.tar.bz2 3948498 RMD160 cdf3ea33c3fd2258c685aea634aca7e9624036ec SHA1 c630222fd6b4272db84f54e68879f81e2014cd51 SHA256 603708301fc3fd7ef1c47bb4a24d7799c26e28db08d69cda240adcbdbff514d7
+DIST ruby-1.8.7-p22.tar.bz2 4121532 RMD160 249253406204151d9448ec43ddc61712556ae023 SHA1 a54e59393f0ca8fcc39f9e23e63a04b1cd4e3b7a SHA256 477968408e27d067ef56f552d7fc2a9e6f5cae2d1a72f17cd838ebf5e0d30149
+DIST ruby-1.9.0-2.tar.bz2 5282728 RMD160 abf70f5380f91f25130edde884deac6035afae60 SHA1 e7253d4b091925c661fe7f57389ab59d8a3e99ff SHA256 913d2bfd03e4285f61e3d343925ab8286ebfc5f7f4a7c861de7a160219cd1351
+EBUILD ruby-1.8.6_p230.ebuild 4964 RMD160 24af86ec063941594663d88051510f5698433cee SHA1 e5b6c667c417748085f14270c7c40618e68fe2e0 SHA256 1158b8d528d072ab55cb61159722aa411f2f1961508d6d7ca6c08ed0f7c03bfc
+EBUILD ruby-1.8.7_p22.ebuild 4932 RMD160 b828a9697b7117e008132b5531734647a0060ca9 SHA1 087d5c4a54eb768c19cb8846257ebb744b1c2038 SHA256 3f314a39f924730c5c05424d38ae6ed76034d2d1b77fa43140bf00c890e6859c
+EBUILD ruby-1.9.0.2.ebuild 4605 RMD160 de4201fab2da67c530f418c1e267aeb27524eecf SHA1 66b433e5cc1293157e31d1e2613c1917cfadb906 SHA256 07ad3bb93eef130777d722b683fdb1c4e190df8f09c29f7b419e13238bd21aa2
+MISC ChangeLog 50106 RMD160 d1794126e560dc87bd45430dc5dd335004658c2a SHA1 6d1947b4efc4110afc7c37db346ea34b384022f0 SHA256 88e6b10104b564a650f809f14fbf0f5492120e1d8c7718cf17f00d317c4b1df1
+MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
diff --git a/dev-lang/ruby/ruby-1.9.0.2.ebuild b/dev-lang/ruby/ruby-1.9.0.2.ebuild
new file mode 100644
index 0000000..48861dc
--- /dev/null
+++ b/dev-lang/ruby/ruby-1.9.0.2.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p111-r1.ebuild,v 1.8 2008/02/17 12:19:21 armin76 Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit autotools eutils flag-o-matic multilib versionator
+
+# ruby-1.9.0.0 -> ruby-1.9.0-0
+MY_P="${PN}-$(replace_version_separator 3 '-')"
+# 1.9.0.0 -> 1.9
+SLOT=$(get_version_component_range 1-2)
+# 1.9 -> 19
+MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.bz2"
+
+LICENSE="Ruby"
+KEYWORDS="alpha ~amd64 ~arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="berkdb debug doc emacs examples gdbm ipv6 rubytests socks5 ssl threads tk xemacs"
+
+RDEPEND="
+ berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ ssl? ( dev-libs/openssl )
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ tk? ( dev-lang/tk )
+ >=dev-ruby/ruby-config-0.3.1
+ !=dev-lang/ruby-cvs-${SLOT}*
+ !dev-ruby/rdoc
+ !dev-ruby/rexml"
+DEPEND="${RDEPEND}"
+PDEPEND="emacs? ( app-emacs/ruby-mode )
+ xemacs? ( app-xemacs/ruby-modes )"
+
+PROVIDE="virtual/ruby"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Fix a hardcoded lib path in configure script
+ sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+ configure.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_compile() {
+ # -fomit-frame-pointer makes ruby segfault, see bug #150413.
+ filter-flags -fomit-frame-pointer
+ # In many places aliasing rules are broken; play it safe
+ # as it's risky with newer compilers to leave it as it is.
+ append-flags -fno-strict-aliasing
+
+ # Socks support via dante
+ if use socks5 ; then
+ # Socks support can't be disabled as long as SOCKS_SERVER is
+ # set and socks library is present, so need to unset
+ # SOCKS_SERVER in that case.
+ unset SOCKS_SERVER
+ fi
+
+ # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+ if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+ append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+ fi
+
+ econf --program-suffix=${MY_SUFFIX} --enable-shared \
+ $(use_enable socks5 socks) \
+ $(use_enable doc install-doc) \
+ $(use_enable threads pthread) \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_with berkdb dbm) \
+ $(use_with gdbm) \
+ $(use_with ssl openssl) \
+ $(use_with tk) \
+ ${myconf} \
+ --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
+ || die "econf failed"
+
+ emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_test() {
+ emake -j1 test || die "make test failed"
+
+ elog "Ruby's make test has been run. Ruby also ships with a make check"
+ elog "that cannot be run until after ruby has been installed."
+ elog
+ if use rubytests; then
+ elog "You have enabled rubytests, so they will be installed to"
+ elog "/usr/share/${PN}-${SLOT}/test. To run them you must be a user other"
+ elog "than root, and you must place them into a writeable directory."
+ elog "Then call: "
+ elog
+ elog "ruby -C /location/of/tests runner.rb"
+ else
+ elog "Enable the rubytests USE flag to install the make check tests"
+ fi
+}
+
+src_install() {
+ LD_LIBRARY_PATH="${D}/usr/$(get_libdir)"
+ RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
+ for d in $(find "${S}/ext" -type d) ; do
+ RUBYLIB="${RUBYLIB}:$d"
+ done
+ export LD_LIBRARY_PATH RUBYLIB
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
+
+ if use doc; then
+ make DESTDIR="${D}" install-doc || die "make install-doc failed"
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}
+ cp -pPR sample "${D}/usr/share/doc/${PF}"
+ fi
+
+ dosym "libruby${MY_SUFFIX}$(get_libname ${PV%_*})" \
+ "/usr/$(get_libdir)/libruby$(get_libname ${PV%.*})"
+ dosym "libruby${MY_SUFFIX}$(get_libname ${PV%_*})" \
+ "/usr/$(get_libdir)/libruby$(get_libname ${PV%_*})"
+
+ dodoc ChangeLog NEWS README* ToDo
+
+ if use rubytests; then
+ dodir /usr/share/${PN}-${SLOT}
+ cp -pPR test "${D}/usr/share/${PN}-${SLOT}"
+ fi
+}
+
+pkg_postinst() {
+ if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
+ "${ROOT}usr/sbin/ruby-config" ruby${MY_SUFFIX}
+ fi
+ elog
+ elog "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
+ elog
+}
+
+pkg_postrm() {
+ if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
+ "${ROOT}usr/sbin/ruby-config" ruby${MY_SUFFIX}
+ fi
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 382a1ef..3062289 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -24,3 +24,7 @@
# Richard Brown <rbrown@gentoo.org> (16 Apr 2008)
# Masked for test
=dev-lang/ruby-1.8.7*
+
+# Sven Schwyn <gentoo@bitcetera.com> (23 Jul 2008)
+# Masked for test
+=dev-lang/ruby-1.9*