aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/docker-api/docker-api-1.28.0.ebuild')
-rw-r--r--dev-ruby/docker-api/docker-api-1.28.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/docker-api/docker-api-1.28.0.ebuild b/dev-ruby/docker-api/docker-api-1.28.0.ebuild
new file mode 100644
index 0000000..7c3cb43
--- /dev/null
+++ b/dev-ruby/docker-api/docker-api-1.28.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple REST client for the Docker Remote API"
+HOMEPAGE="https://github.com/swipely/docker-api"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# Requires docker to be running to perform live tests
+RESTRICT="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/excon-0.38.0
+ dev-ruby/json
+"