aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-04-23 20:44:15 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-04-23 20:44:15 +0000
commitd07476b41ebf9d62a745d51066474bbac9b2b3d2 (patch)
treeefe9be31ccf84a7122743bd7c659a3c842df7a95 /Makefile.am
parentTagged and bagged 1.2 (diff)
downloadsandbox-d07476b41ebf9d62a745d51066474bbac9b2b3d2.tar.gz
sandbox-d07476b41ebf9d62a745d51066474bbac9b2b3d2.tar.bz2
sandbox-d07476b41ebf9d62a745d51066474bbac9b2b3d2.zip
Make sure all functions used in libsandbox.c is declared static. Define
SB_STATIC in localdecls.h for this. Include sandbox_futils.c rather than linking with its object. Hopefully this will fix bug #90153. URL: http://bugs.gentoo.org/90153 Signed-off-by: Martin Schlemmer <azarah@gentoo.org> Reported-by: Alexandre Rostovtsev <tetromino@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 508edac..2d7dc18 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,7 +10,7 @@ AM_CPPFLAGS = -D_GNU_SOURCE -DPIC -fPIC -D_REENTRANT \
dist_pkgdata_DATA = sandbox.bashrc
lib_LTLIBRARIES = libsandbox.la
-libsandbox_la_SOURCES = libsandbox.c sandbox_futils.c localdecls.h
+libsandbox_la_SOURCES = libsandbox.c localdecls.h
# Do not add -nostdlib or -nostartfiles, as then our constructor
# and destructor will not be executed ...
libsandbox_la_LDFLAGS = -nodefaultlibs -lc -ldl