aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-02 04:46:02 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-02 04:46:02 +0000
commite5a2ddec3d454646a656571825c63fa8bddea7f5 (patch)
tree86cc5b89380783d2fdfae4a37ed3d235eed58d5f /Makefile.am
parentscripts to generate/clean build (diff)
downloadsandbox-e5a2ddec3d454646a656571825c63fa8bddea7f5.tar.gz
sandbox-e5a2ddec3d454646a656571825c63fa8bddea7f5.tar.bz2
sandbox-e5a2ddec3d454646a656571825c63fa8bddea7f5.zip
touchups
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 8 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index b42ffed..c06ddae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,28 +1,19 @@
-bin_PROGRAMS = sandbox
-lib_LTLIBRARIES = libsandbox.la
-datadir = @datadir@
-AM_CFLAGS = -D_GNU_SOURCE -DPIC -fPIC -D_REENTRANT
+AUTOMAKE_OPTIONS = dist-bzip2 no-dist-gzip
+dist_pkgdata_DATA = sandbox.bashrc
+EXTRA_DIST = sandbox.bashrc canonicalize.c create-localdecls libctest.c
+AM_CFLAGS = -D_GNU_SOURCE -DPIC -fPIC -D_REENTRANT
+lib_LTLIBRARIES = libsandbox.la
libsandbox_la_SOURCES = libsandbox.c sandbox_futils.c localdecls.h
libsandbox_la_LDFLAGS = -Wc,-nostdlib -lc -ldl
libsandbox_la_CFLAGS = -Wc,-nostdlib -D_REENTRANT -D_GNU_SOURCE \
-DSANDBOX_BASHRC_PATH=\"$(pkgdatadir)\" \
-DLIBSANDBOX_PATH=\"$(libdir)\"
-
+bin_PROGRAMS = sandbox
sandbox_SOURCES = sandbox.c sandbox.h sandbox_futils.c getcwd.c
-sandbox_CFLAGS = -DSANDBOX_BASHRC_PATH=\"$(pkgdatadir)\" \
- -DLIBSANDBOX_PATH=\"$(libdir)\"
+sandbox_CFLAGS = -DSANDBOX_BASHRC_PATH=\"$(pkgdatadir)\" -DLIBSANDBOX_PATH=\"$(libdir)\"
BUILT_SOURCES = localdecls.h
-
-dist_pkgdata_DATA = sandbox.bashrc
-
-localdecls.h: Makefile
+localdecls.h: Makefile
./create-localdecls
-
-AUTOMAKE_OPTIONS = dist-bzip2 no-dist-gzip
-EXTRA_DIST = sandbox.bashrc canonicalize.c create-localdecls libctest.c
-
-libctest.c:
-canonicalize.c: