aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReinis Danne <rei4dan@gmail.com>2016-02-10 15:48:14 +0200
committerReinis Danne <rei4dan@gmail.com>2016-02-10 15:48:14 +0200
commit0fea6abf5717468137b9963ea260b8e7f0b6c67d (patch)
tree0656747ff9eade20215a81538c08d90bd9199dd3
parentsci-biology/SnpEff: version bump (diff)
downloadsci-wxmacmolplt.tar.gz
sci-wxmacmolplt.tar.bz2
sci-wxmacmolplt.zip
sci-chemistry/wxmacmolplt: Bump to version 7.6.2wxmacmolplt
-rw-r--r--sci-chemistry/wxmacmolplt/Manifest1
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.6.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-chemistry/wxmacmolplt/Manifest b/sci-chemistry/wxmacmolplt/Manifest
index 13cf4a771..5eb39df38 100644
--- a/sci-chemistry/wxmacmolplt/Manifest
+++ b/sci-chemistry/wxmacmolplt/Manifest
@@ -1 +1,2 @@
DIST wxmacmolplt-7.6.1.tar.gz 2353688 SHA256 930e7afd00fe1af68a2b4fdfef15aad1527ab36dd385c85d71bff98edcbbede1 SHA512 d8e3b531150d895f3c746eb9beb27525103e4e90fb1782f2c862cd914d276e65e41cec5d48fda5d579e7bc865092c16b17fa988314b8d7062ebd9ef0aa3bf476 WHIRLPOOL 6ea77b282eea96bf9cd1c4fb92a4d6ea77f0c52c2f99508afa176f5ffc3dc3f5085c0dc17ccfb8e0db3f3ebcd432fd9e56abb20101b204f88f951b5746c04b6d
+DIST wxmacmolplt-7.6.2.tar.gz 2360572 SHA256 27f08f86b78d446f87483df689f0f972638048aa2cf38e42126468e305587076 SHA512 6b7c36f3833b7fda984c9c05a361185912a9bb447409c74cdd60835df9c68ab8ce1a47596ff365f4dc6f70566b64ab185dc57367975d16bec1ec27159515b711 WHIRLPOOL f79809067fc1dec9f4230a324d16d1435fe42c703c654f03416aa7ea65883e470d484f239af889c011e9dd06baf3ecd05f0258a6e5e05b4d310140f862a71017
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.6.2.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.6.2.ebuild
new file mode 100644
index 000000000..028ff6f62
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.6.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER=3.0
+
+inherit autotools eutils wxwidgets
+
+DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
+HOMEPAGE="http://brettbode.github.io/wxmacmolplt/"
+SRC_URI="https://github.com/brettbode/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="flash"
+
+RDEPEND="
+ media-libs/glew
+ media-libs/mesa
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
+ flash? ( media-libs/ming )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch_user
+
+ sed \
+ -e "/^dist_doc_DATA/d" \
+ -i Makefile.am || die "Failed to disable installation of LICENSE file"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-glew \
+ $(use_with flash ming)
+}
+
+src_install() {
+ default
+ doicon resources/${PN}.png
+ make_desktop_entry ${PN} wxMacMolPlt ${PN} "Science;DataVisualization;"
+}