aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Vig <sean.v.775@gmail.com>2015-09-03 13:39:22 -0500
committerSean Vig <sean.v.775@gmail.com>2015-09-22 09:17:46 -0500
commit004415190a1d4f3c7b911256b0241ff4dafb9b3d (patch)
treef4bcf3582dff8ad84f8bc07c125f74f71c44cb13
parentwww-client/casperjs: Initial ebuild (diff)
downloadsci-004415190a1d4f3c7b911256b0241ff4dafb9b3d.tar.gz
sci-004415190a1d4f3c7b911256b0241ff4dafb9b3d.tar.bz2
sci-004415190a1d4f3c7b911256b0241ff4dafb9b3d.zip
dev-python/notebok: Add javascript tests
-rw-r--r--dev-python/notebook/ChangeLog4
-rw-r--r--dev-python/notebook/notebook-4.0.5.ebuild6
-rw-r--r--dev-python/notebook/notebook-9999.ebuild6
3 files changed, 16 insertions, 0 deletions
diff --git a/dev-python/notebook/ChangeLog b/dev-python/notebook/ChangeLog
index 2d7e2ea93..215864292 100644
--- a/dev-python/notebook/ChangeLog
+++ b/dev-python/notebook/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 03 Sep 2015; Sean Vig <sean.v.775@gmail.com> notebook-4.0.5.ebuild,
+ notebook-9999.ebuild:
+ dev-python/notebook: Add javascript tests
+
*notebook-4.0.5 (22 Sep 2015)
22 Sep 2015; Marius Brehler <marbre@linux.sungazer.de> +notebook-4.0.5.ebuild:
diff --git a/dev-python/notebook/notebook-4.0.5.ebuild b/dev-python/notebook/notebook-4.0.5.ebuild
index 1989a1a0e..80fa9fc1f 100644
--- a/dev-python/notebook/notebook-4.0.5.ebuild
+++ b/dev-python/notebook/notebook-4.0.5.ebuild
@@ -35,6 +35,7 @@ DEPEND="${RDEPEND}
>=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
+ www-client/casperjs
)
doc? (
app-text/pandoc
@@ -66,6 +67,11 @@ python_compile_all() {
python_test() {
nosetests --with-coverage --cover-package=notebook notebook || die
+
+ "${PYTHON}" -m notebook.jstest base || die
+ "${PYTHON}" -m notebook.jstest notebook || die
+ "${PYTHON}" -m notebook.jstest services || die
+ "${PYTHON}" -m notebook.jstest tree || die
}
python_install() {
diff --git a/dev-python/notebook/notebook-9999.ebuild b/dev-python/notebook/notebook-9999.ebuild
index 0d2e0f910..d5ab6df53 100644
--- a/dev-python/notebook/notebook-9999.ebuild
+++ b/dev-python/notebook/notebook-9999.ebuild
@@ -34,6 +34,7 @@ DEPEND="${RDEPEND}
>=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
+ www-client/casperjs
)
doc? (
app-text/pandoc
@@ -65,6 +66,11 @@ python_compile_all() {
python_test() {
nosetests --with-coverage --cover-package=notebook notebook || die
+
+ "${PYTHON}" -m notebook.jstest base || die
+ "${PYTHON}" -m notebook.jstest notebook || die
+ "${PYTHON}" -m notebook.jstest services || die
+ "${PYTHON}" -m notebook.jstest tree || die
}
python_install() {