aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2013-07-15 06:55:36 -0700
committerSébastien Fabbro <bicatali@gentoo.org>2013-07-15 06:55:36 -0700
commit009edaac5d6d10aabae9e2bc5e11fae02f11277f (patch)
tree18ff9841f7f8d98fd755fe84828b0cad90de283e
parentsci-libs/coinhsl: Version bump. Removed restriction on parallel building (diff)
parentMerge pull request #91 from jhcloos/julia (diff)
downloadsci-009edaac5d6d10aabae9e2bc5e11fae02f11277f.tar.gz
sci-009edaac5d6d10aabae9e2bc5e11fae02f11277f.tar.bz2
sci-009edaac5d6d10aabae9e2bc5e11fae02f11277f.zip
Merge github.com:gentoo-science/sci
-rw-r--r--dev-lang/julia/ChangeLog3
-rw-r--r--dev-lang/julia/julia-9999.ebuild1
-rw-r--r--sci-visualization/gnuplot/ChangeLog3
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild15
4 files changed, 8 insertions, 14 deletions
diff --git a/dev-lang/julia/ChangeLog b/dev-lang/julia/ChangeLog
index 4bc1c8e2b..be886b3e9 100644
--- a/dev-lang/julia/ChangeLog
+++ b/dev-lang/julia/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 14 Jul 2013; James Cloos <cloos@jhcloos.com> julia-9999.ebuild:
+ Julia uses submodules, so set EGIT_HAS_SUBMODULES=yes
+
14 Jun 2013; Justin Lecher <jlec@gentoo.org> julia-9999.ebuild, metadata.xml:
Drop KEYWORDS of live ebuilds
diff --git a/dev-lang/julia/julia-9999.ebuild b/dev-lang/julia/julia-9999.ebuild
index 99aa27aa9..23d97d81d 100644
--- a/dev-lang/julia/julia-9999.ebuild
+++ b/dev-lang/julia/julia-9999.ebuild
@@ -5,6 +5,7 @@
EAPI=5
EGIT_REPO_URI="git://github.com/JuliaLang/julia.git"
+EGIT_HAS_SUBMODULES=yes
inherit git-2 elisp-common eutils multilib
diff --git a/sci-visualization/gnuplot/ChangeLog b/sci-visualization/gnuplot/ChangeLog
index bd5604411..539d7ecdf 100644
--- a/sci-visualization/gnuplot/ChangeLog
+++ b/sci-visualization/gnuplot/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 14 Jul 2013; Christoph Junghans <ottxor@gentoo.org> gnuplot-4.7.9999.ebuild:
+ build of info file broke again, drop it, will be shipped in the release anyhow
+
19 Jun 2013; Christoph Junghans <ottxor@gentoo.org> gnuplot-4.7.9999.ebuild:
fixed qt4 build
diff --git a/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild b/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild
index c22c039bf..4446c06ac 100644
--- a/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild
@@ -63,12 +63,6 @@ DEPEND="${RDEPEND}
app-text/ghostscript-gpl )
!emacs? ( xemacs? ( app-xemacs/texinfo ) )"
-if [[ -z ${PV%%*9999} ]]; then
- # The live ebuild always needs an Emacs for building of gnuplot.texi
- DEPEND="${DEPEND}
- || ( virtual/emacs app-xemacs/texinfo )"
-fi
-
S="${WORKDIR}/${MY_P}"
GP_VERSION="${PV%.*}"
@@ -131,13 +125,6 @@ src_configure() {
else
emacs=no
lispdir=""
- if [[ -z ${PV%%*9999} ]]; then
- # Live ebuild needs an Emacs to build gnuplot.texi
- if has_version virtual/emacs; then emacs=emacs
- elif has_version app-xemacs/texinfo; then emacs=xemacs; fi
- # with emtpy lispdir info cannot be build
- lispdir="${T}"
- fi
fi
econf \
@@ -171,7 +158,7 @@ src_compile() {
# In case of problems file a bug report at bugs.gentoo.org.
#addwrite /dev/svga:/dev/mouse:/dev/tts/0
- emake all info
+ emake all
if use doc; then
# Avoid sandbox violation in epstopdf/ghostscript