aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-09-18 14:53:22 +0200
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-09-18 14:54:08 +0200
commit018be86d553372b2ee4acce08179711a2e8cb61e (patch)
tree79de790e469df23442785d3be633d2599fa498fa
parentccpn version bump and rewrittings (diff)
downloadsci-018be86d553372b2ee4acce08179711a2e8cb61e.tar.gz
sci-018be86d553372b2ee4acce08179711a2e8cb61e.tar.bz2
sci-018be86d553372b2ee4acce08179711a2e8cb61e.zip
sci-chemistry/pymol-plugins-bni-tools added
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/ChangeLog15
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/Manifest4
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/metadata.xml10
-rw-r--r--sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.25.ebuild40
4 files changed, 69 insertions, 0 deletions
diff --git a/sci-chemistry/pymol-plugins-bni-tools/ChangeLog b/sci-chemistry/pymol-plugins-bni-tools/ChangeLog
new file mode 100644
index 000000000..068f40870
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-bni-tools/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for sci-chemistry/pymol-plugins-bni-tools
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*pymol-plugins-bni-tools-0.25 (18 Sep 2009)
+
+ 18 Sep 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +pymol-plugins-bni-tools-0.25.ebuild, +metadata.xml:
+ moved to sci overlay
+ version bump
+
+ 06 Jan 2009; justin Lecher (jlec) <jlec@j-schmitz.net>
+ +pymol-plugins-bnitools-0.21.ebuild:
+ Setup sci-chemistry/pymol-plugins-bnitools
+
diff --git a/sci-chemistry/pymol-plugins-bni-tools/Manifest b/sci-chemistry/pymol-plugins-bni-tools/Manifest
new file mode 100644
index 000000000..87808a82b
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-bni-tools/Manifest
@@ -0,0 +1,4 @@
+DIST bni-tools-0.25.zip 32544 RMD160 0648ea2c60d59ed4a4ecf4785fc2de7bfe7dd305 SHA1 90603832b27878515f5e438f960eaad005ce9f65 SHA256 1d93606d5ad3ef82562f8b0b41f7c4acd75b1dc86381a2e8aecab274f919ef1c
+EBUILD pymol-plugins-bni-tools-0.25.ebuild 834 RMD160 674ec8de3b165124f8865fcd4b790883fac58836 SHA1 10216f299280ceb0f011e7476631624ef757a5f1 SHA256 78298e9d1205d92b8b1a8dab8fc52c8b190d93e686e654d19b51972f1650d4be
+MISC ChangeLog 476 RMD160 b6b242247010de0a29ddacff4f6dab9db83c57a0 SHA1 539cf5dc430505296cee45fc4e70429efb645825 SHA256 9794cedbdefc8aafa42cd7f9e48f1f4a74c4d2bbca5a1f3765d2f0f4bc3b935e
+MISC metadata.xml 270 RMD160 2ec69368c772133030ecea0fa9c33828402e697b SHA1 93e10a24e226db07625d82ea564a7c643429d94f SHA256 2096a77fef624421b65ccb516a1a44dd30401a3cae3f15629dda4b2c36dcb370
diff --git a/sci-chemistry/pymol-plugins-bni-tools/metadata.xml b/sci-chemistry/pymol-plugins-bni-tools/metadata.xml
new file mode 100644
index 000000000..2f8d3bc31
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-bni-tools/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>molmod-overlay</herd>
+ <maintainer>
+ <email>jlec@j-schmitz.net</email>
+ <name>Justin Lecher (jlec)</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.25.ebuild b/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.25.ebuild
new file mode 100644
index 000000000..73aa0253d
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-bni-tools/pymol-plugins-bni-tools-0.25.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit python
+
+MY_PN="${PN#pymol-plugins-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Gives Pymol additional functionalities and presets to the PyMOL GUI"
+HOMEPAGE="http://bni-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.zip"
+
+LICENSE="CNRI"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+RDEPEND="sci-chemistry/pymol"
+DEPEND="app-arch/unzip"
+
+src_compile(){
+ true
+}
+
+src_install(){
+ insinto $(python_get_sitedir)/pmg_tk/startup/
+ doins bni-tools.py || die "Failed to install ${P}"
+ dodoc readme.txt || die "No dodoc"
+}
+
+pkg_postinst(){
+ python_mod_optimize "${ROOT%/}"$(python_get_sitedir)/pmg_tk/startup/
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${ROOT%/}"$(python_get_sitedir)/pmg_tk/startup/
+}
+