aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-22 20:47:48 -0400
committerAisha Tammy <gentoo@aisha.cc>2020-09-22 20:47:48 -0400
commit01bbb397122ad4d7cfef58a8febb2b03f0e8ccb1 (patch)
tree26d7343fc8ba5e427a53f7eb8c9fee90b19976b9
parentsci-misc/nltk: drop package (diff)
downloadsci-01bbb397122ad4d7cfef58a8febb2b03f0e8ccb1.tar.gz
sci-01bbb397122ad4d7cfef58a8febb2b03f0e8ccb1.tar.bz2
sci-01bbb397122ad4d7cfef58a8febb2b03f0e8ccb1.zip
dev-python/python-igraph: py3 bindings for igraph
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--dev-python/python-igraph/Manifest1
-rw-r--r--dev-python/python-igraph/metadata.xml12
-rw-r--r--dev-python/python-igraph/python-igraph-0.8.2.ebuild36
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python-igraph/Manifest b/dev-python/python-igraph/Manifest
new file mode 100644
index 000000000..c06f6e8dc
--- /dev/null
+++ b/dev-python/python-igraph/Manifest
@@ -0,0 +1 @@
+DIST python-igraph-0.8.2.tar.gz 3970354 BLAKE2B 2107a147ad98fa0b1a6c4f7332167a4256225615b9ef457e7c4b39c63cbe97456b4952e7c208ab0712365e1103eb541f4f8d0f0554470132b05b57bcc8f1dc67 SHA512 669d44081de2f0e1d0ef5b06e1cced193a9a0686e3e5e58b8334fd6eef14df3226cd0f7902f88289e575c822516e85b442c89ca9ec73a0d9d48ac8522347a30a
diff --git a/dev-python/python-igraph/metadata.xml b/dev-python/python-igraph/metadata.xml
new file mode 100644
index 000000000..e97c4322a
--- /dev/null
+++ b/dev-python/python-igraph/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-igraph/python-igraph-0.8.2.ebuild b/dev-python/python-igraph/python-igraph-0.8.2.ebuild
new file mode 100644
index 000000000..0b2883896
--- /dev/null
+++ b/dev-python/python-igraph/python-igraph-0.8.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for igraph"
+HOMEPAGE="https://igraph.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/igraph
+ dev-python/texttable[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile --use-pkg-config
+}