aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <sebfabbro@gmail.com>2012-06-16 01:40:40 +0100
committerSébastien Fabbro <sebfabbro@gmail.com>2012-06-16 01:40:40 +0100
commit01cd6aa205e6fc62ae5899b3769a28c189b24984 (patch)
tree807091ae433050715b947a486ae9a8373be1584a
parentdev-perl/File-Map: Initial import (diff)
downloadsci-01cd6aa205e6fc62ae5899b3769a28c189b24984.tar.gz
sci-01cd6aa205e6fc62ae5899b3769a28c189b24984.tar.bz2
sci-01cd6aa205e6fc62ae5899b3769a28c189b24984.zip
dev-perl/OpenGL: Initial import
(Portage version: 2.1.10.63/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-perl/OpenGL/ChangeLog10
-rw-r--r--dev-perl/OpenGL/Manifest1
-rw-r--r--dev-perl/OpenGL/OpenGL-0.66.ebuild34
-rw-r--r--dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch50
-rw-r--r--dev-perl/OpenGL/metadata.xml16
5 files changed, 111 insertions, 0 deletions
diff --git a/dev-perl/OpenGL/ChangeLog b/dev-perl/OpenGL/ChangeLog
new file mode 100644
index 000000000..7b4870902
--- /dev/null
+++ b/dev-perl/OpenGL/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-perl/OpenGL
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*OpenGL-0.66 (16 Jun 2012)
+
+ 16 Jun 2012; Sébastien Fabbro <bicatali@gentoo.org> +OpenGL-0.66.ebuild,
+ +files/OpenGL-0.66-no-display.patch, +metadata.xml:
+ dev-perl/OpenGL: Initial import
+
diff --git a/dev-perl/OpenGL/Manifest b/dev-perl/OpenGL/Manifest
new file mode 100644
index 000000000..6688bd35f
--- /dev/null
+++ b/dev-perl/OpenGL/Manifest
@@ -0,0 +1 @@
+DIST OpenGL-0.66.tar.gz 611606 RMD160 cf0d4d6b726e4e69b2f861b3a813c8e4ce5c34cf SHA1 e5245eeb00b3a96e2333a4de6c0f36898d8797c6 SHA256 8837bf244d41e415e9ef05bece8fb60861293389d96a4115f0a64929650627df SHA512 5ab52ab70a5288b48ffcee36d153e93bfb72b02296a950c6c86afb303224bd7ec87342cf065fceeda36bf875767618bd5dcf62455368625e14d6e1acebbf1707 WHIRLPOOL 5827abf6aa4659c356ddb9e7ec865ed8c183d337aa4a732be87c5022f1d8a84895f7310d41d06811512a440c0a81908f89a322c5411471906a061785bedeb593
diff --git a/dev-perl/OpenGL/OpenGL-0.66.ebuild b/dev-perl/OpenGL/OpenGL-0.66.ebuild
new file mode 100644
index 000000000..e3aa5cd26
--- /dev/null
+++ b/dev-perl/OpenGL/OpenGL-0.66.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+MODULE_AUTHOR="CHM"
+
+inherit perl-module eutils
+
+DESCRIPTION="Perl interface providing graphics display using OpenGL"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/freeglut
+ x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+mydoc="Release_Notes"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-display.patch
+}
+
+src_compile() {
+ sed -i -e 's/PERL_DL_NONLAZY=1//' Makefile || die
+ perl-module_src_compile
+}
diff --git a/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch b/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch
new file mode 100644
index 000000000..6bdc334ba
--- /dev/null
+++ b/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch
@@ -0,0 +1,50 @@
+Don't check current display for extensions, build all.
+
+diff -up OpenGL-0.62/Makefile.PL.dist OpenGL-0.62/Makefile.PL
+--- OpenGL-0.62/Makefile.PL.dist 2009-12-11 01:10:00.000000000 +0100
++++ OpenGL-0.62/Makefile.PL 2010-01-07 13:00:26.000000000 +0100
+@@ -579,9 +579,9 @@ my $build_config =
+ {
+ FILES =>
+ "Config.pm ".
+- "utils/glversion.txt ".
+- "utils/glversion$Config{exe_ext} ".
+- "utils/glversion$Config{obj_ext}"
++ "utils/glversion.txt "
++ #"utils/glversion$Config{exe_ext} ".
++ #"utils/glversion$Config{obj_ext}"
+ }
+ };
+
+@@ -790,6 +790,7 @@ sub get_extensions
+ print "GLUT not found\n";
+ }
+
++=cut
+ # Platform-specific makefiles for glversion
+ my $make_ver;
+ if ($IS_MINGW)
+@@ -848,7 +849,9 @@ sub get_extensions
+ print "get_extensions: no extensions found in $glv_file\n" if $verbose;
+ return '';
+ }
+-
++=cut
++ use Config;
++ my $gldata = { };
+
+ # Parse glext_procs.h file
+ return '' if (!open(GLEXT,"glext_procs.h"));
+@@ -867,10 +870,12 @@ sub get_extensions
+
+ # Create gl_exclude.h
+ die "Unable to write to $exc_file\n" if (!open(GLEXC,">$exc_file"));
++=cut
+ print GLEXC "// OpenGL Extension Exclusions - may be modified before building.\n";
+ print GLEXC "//\n";
+ print GLEXC "// Generated for ".$gldata->{VENDOR}.", ".$gldata->{RENDERER}."\n";
+ print GLEXC "// OpenGL v".$gldata->{VERSION}.", using ";
++=cut
+
+ # Fix GLUT flags based on results
+ if ($gldata->{GLUT} > 0)
diff --git a/dev-perl/OpenGL/metadata.xml b/dev-perl/OpenGL/metadata.xml
new file mode 100644
index 000000000..44f1713de
--- /dev/null
+++ b/dev-perl/OpenGL/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<herd>perl</herd>
+<longdescription lang="en">
+ OpenGL is a Perl module that provides an interface to most of Open Graphics
+ Library, API versions 1.0, 1.1 and 1.2. There is full support for the Utility
+ Toolkit (GLUT) up to version 3 and provides some additional functionality via
+ partial support for the Utility Library (GLU). It also provides functionality
+ to use the X Window System (through X11 and GLX) as an alternative to GLUT.
+</longdescription>
+<upstream>
+ <remote-id type="cpan">OpenGL</remote-id>
+</upstream>
+</pkgmetadata>