aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-09-12 10:41:06 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-09-12 10:41:06 +0200
commit01d67b4f066fe470068ec0da85ad0d8fb70edd0d (patch)
tree33c2c4fc7edf646e1d84b14ab8774cdf05b1d053
parentsci-libs/clfft: Add client and examples use flag (diff)
downloadsci-01d67b4f066fe470068ec0da85ad0d8fb70edd0d.tar.gz
sci-01d67b4f066fe470068ec0da85ad0d8fb70edd0d.tar.bz2
sci-01d67b4f066fe470068ec0da85ad0d8fb70edd0d.zip
sci-libs/clblas: Version bump
Package-Manager: portage-2.2.20.1
-rw-r--r--sci-libs/clblas/ChangeLog5
-rw-r--r--sci-libs/clblas/Manifest1
-rw-r--r--sci-libs/clblas/clblas-2.6.ebuild57
3 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/clblas/ChangeLog b/sci-libs/clblas/ChangeLog
index 09bde5982..e74dc52e0 100644
--- a/sci-libs/clblas/ChangeLog
+++ b/sci-libs/clblas/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+*clblas-2.6 (12 Sep 2015)
+
+ 12 Sep 2015; Marius Brehler <marbre@linux.sungazer.de> +clblas-2.6.ebuild:
+ sci-libs/clblas: Version bump
+
06 Sep 2015; Marius Brehler <marbre@linux.sungazer.de>
+files/clblas-2.4-samples_CMakeLists.patch,
+files/clblas-2.4-scripts_perf_CMakeLists.patch,
diff --git a/sci-libs/clblas/Manifest b/sci-libs/clblas/Manifest
index 47dd24365..e2810c287 100644
--- a/sci-libs/clblas/Manifest
+++ b/sci-libs/clblas/Manifest
@@ -1 +1,2 @@
DIST clblas-2.4.tar.gz 800848 SHA256 3e9b8e138c465df1daff0235d9c93b0005986a7257a3739aea2d4c8b60b7ed37 SHA512 ae8c1fc1bef7573b12279977fc32f9e97c9b81b9167994ca6f352587a670dcee0f486ab2b7d5191092324f5e8fc00f9a2ea29303a026a0c1201be31d384cafe7 WHIRLPOOL a97537d7390055ad608eeac66679362956db7acfa96cf1165581ff8f9adfe309b8ff8231225bd8ca6247c8f588bff24d6f648e131cec52f8e3093168a3f26f82
+DIST clblas-2.6.tar.gz 954586 SHA256 4607561a648949709bc7c368be4aaf7346174406e678454b643e31cfe861830c SHA512 76756707c8a217b926dff4c288ce48700e21a80650e14b25f81615b25bb81c47e328900e94712ba9bcd5690f29647b4782157df85623cfe1c696f3698fcd62d6 WHIRLPOOL e1a8f596a187216b69a339919601dec978ad43728f9a5965454139d53391a2ac25314d6be28eef52cfdff43551d72f07b0bf6145a931d643731f5969b7f13379
diff --git a/sci-libs/clblas/clblas-2.6.ebuild b/sci-libs/clblas/clblas-2.6.ebuild
new file mode 100644
index 000000000..2a7b07bd8
--- /dev/null
+++ b/sci-libs/clblas/clblas-2.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+MY_PN="clBLAS"
+
+DESCRIPTION="A software library containing BLAS routines for OpenCL"
+HOMEPAGE="https://github.com/clMathLibraries/clBLAS"
+SRC_URI="https://github.com/clMathLibraries/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+S="${WORKDIR}/${MY_PN}-${PV}/src"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+client examples +ktest performance test"
+
+RDEPEND="
+ >=sys-devel/gcc-4.6:*
+ virtual/opencl
+ || ( >=dev-util/amdapp-2.9 dev-util/intel-ocl-sdk )
+ dev-libs/boost
+ performance? ( ${PYTHON_DEPS} )
+ "
+DEPEND="${RDEPEND}"
+# test? (
+# >=dev-cpp/gtest-1.6.0
+# >=sci-libs/acml-6.1.0.3
+# )"
+
+# The tests only get compiled to an executable named Test, which is not recogniozed by cmake.
+# Therefore src_test() won't execute any test.
+RESTRICT="test"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(gcc-major-version) -lt 4 ]] || ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) ; then
+ die "Compilation with gcc older than 4.6 is not supported."
+ fi
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build client CLIENT)
+ $(cmake-utils_use_build examples SAMPLE)
+ $(cmake-utils_use_build ktest KTEST)
+ $(cmake-utils_use_build performance PERFORMANCE)
+ $(cmake-utils_use_build test TEST)
+ )
+ cmake-utils_src_configure
+}