aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-03 10:04:59 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-03 10:04:59 +0100
commit01f1f9614518266404ea72721cb2fb03ebbd6bcd (patch)
tree29a02a31f4c3e3a605a496b50c0a45e65b91b7dd
parentapp-text/zotero-bin: remove double PV (diff)
downloadsci-01f1f9614518266404ea72721cb2fb03ebbd6bcd.tar.gz
sci-01f1f9614518266404ea72721cb2fb03ebbd6bcd.tar.bz2
sci-01f1f9614518266404ea72721cb2fb03ebbd6bcd.zip
dev-java/flexdock: EAPI bump
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--dev-java/flexdock/flexdock-1.2.4.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/dev-java/flexdock/flexdock-1.2.4.ebuild b/dev-java/flexdock/flexdock-1.2.4.ebuild
index 67dc18337..64898244e 100644
--- a/dev-java/flexdock/flexdock-1.2.4.ebuild
+++ b/dev-java/flexdock/flexdock-1.2.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-ant-2
@@ -14,18 +14,20 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=virtual/jre-1.5"
-DEPEND=">=virtual/jdk-1.5
- app-arch/unzip
- dev-java/skinlf"
+RDEPEND=">=virtual/jre-1.5:=
+ dev-java/skinlf:0"
+BDEPEND="app-arch/unzip"
+DEPEND="${RDEPEND}"
EANT_BUILD_TARGET="jar"
EANT_DOC_TARGET="doc"
-java_prepare() {
- epatch "${FILESDIR}"/${P}-nodemo.patch
+PATCHES=(
+ "${FILESDIR}/${P}-nodemo.patch"
+)
+
+src_prepare() {
+ default
#some cleanups
find . -name '*.so' -exec rm -v {} \;|| die