aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2010-02-25 17:29:56 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2010-02-25 17:36:46 +0000
commit03061911f5e53c5e1dbd5230308b5f1005dd804b (patch)
treeb42f382239d1b6fe0f755432357cbf01d8b86181
parentMasked >=jgraphx1.3, unmasked scilab for wider exposure (diff)
downloadsci-03061911f5e53c5e1dbd5230308b5f1005dd804b.tar.gz
sci-03061911f5e53c5e1dbd5230308b5f1005dd804b.tar.bz2
sci-03061911f5e53c5e1dbd5230308b5f1005dd804b.zip
Cleaning scilab
-rw-r--r--sci-mathematics/scilab/files/ImplicitPointerConversions.diff22
-rw-r--r--sci-mathematics/scilab/scilab-5.2.0-r3.ebuild143
2 files changed, 0 insertions, 165 deletions
diff --git a/sci-mathematics/scilab/files/ImplicitPointerConversions.diff b/sci-mathematics/scilab/files/ImplicitPointerConversions.diff
deleted file mode 100644
index d1fc11924..000000000
--- a/sci-mathematics/scilab/files/ImplicitPointerConversions.diff
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Nur -x '*.orig' -x '*~' scilab-5.2.0/modules/fileio/sci_gateway/c/sci_copyfile.c scilab-5.2.0.new/modules/fileio/sci_gateway/c/sci_copyfile.c
---- scilab-5.2.0/modules/fileio/sci_gateway/c/sci_copyfile.c 2009-12-16 08:24:45.000000000 +0100
-+++ scilab-5.2.0.new/modules/fileio/sci_gateway/c/sci_copyfile.c 2010-01-18 13:22:03.360717656 +0100
-@@ -24,6 +24,7 @@
- #include "isdir.h"
- #include "splitpath.h"
- #include "freeArrayOfString.h"
-+#include "charEncoding.h"
- /*--------------------------------------------------------------------------*/
- static wchar_t* getFilenameWithExtension(wchar_t* wcFullFilename);
- static void returnCopyFileResultOnStack(int ierr, char *fname);
-diff -Nur -x '*.orig' -x '*~' scilab-5.2.0/modules/fileio/sci_gateway/c/sci_movefile.c scilab-5.2.0.new/modules/fileio/sci_gateway/c/sci_movefile.c
---- scilab-5.2.0/modules/fileio/sci_gateway/c/sci_movefile.c 2009-12-16 08:24:45.000000000 +0100
-+++ scilab-5.2.0.new/modules/fileio/sci_gateway/c/sci_movefile.c 2010-01-18 13:21:09.540737969 +0100
-@@ -24,6 +24,7 @@
- #include "isdir.h"
- #include "splitpath.h"
- #include "freeArrayOfString.h"
-+#include "charEncoding.h"
- /*--------------------------------------------------------------------------*/
- static wchar_t* getFilenameWithExtensionForMove(wchar_t* wcFullFilename);
- static void returnMoveFileResultOnStack(int ierr, char *fname);
diff --git a/sci-mathematics/scilab/scilab-5.2.0-r3.ebuild b/sci-mathematics/scilab/scilab-5.2.0-r3.ebuild
deleted file mode 100644
index 87949e8d5..000000000
--- a/sci-mathematics/scilab/scilab-5.2.0-r3.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=2
-inherit eutils autotools java-pkg-2 check-reqs
-
-DESCRIPTION="Scientific software package for numerical computations"
-LICENSE="CeCILL-2"
-SRC_URI="http://www.scilab.org/download/${PV}/${P}-src.tar.gz"
-HOMEPAGE="http://www.scilab.org/"
-
-SLOT="0"
-IUSE="doc fftw +gui hdf5 +matio nls tk +umfpack xcos"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="virtual/lapack
- tk? ( dev-lang/tk )
- xcos? ( dev-lang/ocaml )
- umfpack? ( sci-libs/umfpack )
- gui? ( >=virtual/jre-1.5
- dev-java/commons-logging
- dev-java/flexdock
- dev-java/gluegen
- dev-java/jeuclid-core
- dev-java/jlatexmath
- dev-java/jgraphx
- dev-java/jogl
- dev-java/jgoodies-looks
- dev-java/skinlf
- dev-java/jrosetta
- dev-java/javahelp
- hdf5? ( dev-java/hdf-java ) )
- fftw? ( sci-libs/fftw:3.0 )
- matio? ( sci-libs/matio )
- hdf5? ( sci-libs/hdf5 )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? (
- ~dev-java/saxon-6.5.5
- dev-java/fop
- dev-java/batik
- app-text/docbook-xsl-stylesheets )"
-
-pkg_setup() {
- CHECKREQS_MEMORY="512"
- java-pkg-2_pkg_setup
-}
-
-src_prepare() {
- # avoid redefinition of exp10
- epatch "${FILESDIR}"/${P}-no-redef-exp10.patch
- # Increases java heap to 512M when available, when building docs
- check_reqs_conditional && epatch "${FILESDIR}"/${P}-java-heap.patch
- # fix detection of various java packages for docs
- epatch "${FILESDIR}"/${P}-disable-build-help-failed.patch
- # fix for hdf-java-2.6
- epatch "${FILESDIR}"/${P}-hdf-java-2.6.patch
- # fix for jgraphx
- epatch "${FILESDIR}"/${P}-jgraphx.patch
- # fix SCILIB path
- epatch "${FILESDIR}"/${P}-scilib-fix.patch
-
- # apply blindly some debian patches
- for i in "${FILESDIR}"/*.diff; do
- epatch ${i}
- done
-
- # add the correct java directories to the config file
- sed \
- -i "/^.DEFAULT_JAR_DIR/{s|=.*|=\"$(echo $(ls -d /usr/share/*/lib))\"|}" \
- m4/java.m4 || die
-
- sed -i "s|-L\$SCI_SRCDIR/bin/|-L\$SCI_SRCDIR/bin/ \
- -L$(java-config -i gluegen) \
- -L$(java-config -i hdf-java) \
- -L$(java-config -i jogl)|" \
- configure.ac || die
- sed -i \
- -e "/<\/librarypaths>/i\<path value=\"$(java-config -i gluegen)\"\/>" \
- -e "/<\/librarypaths>/i\<path value=\"$(java-config -i jogl)\"\/>" \
- -e "/<\/librarypaths>/i\<path value=\"$(java-config -i hdf-java)\"\/>" \
- etc/librarypath.xml || die
- eautoreconf
- java-pkg-2_src_prepare
-}
-
-src_configure() {
- local myopts
- use doc && myopts="--with-docbook=/usr/share/sgml/docbook/xsl-stylesheets"
- export JAVA_HOME=$(java-config -O)
- export BLAS_LIBS="$(pkg-config --libs blas)"
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
- # mpi is only used for hdf5 i/o
- if use hdf5 && has_version sci-libs/hdf5[mpi]; then
- export CC=mpicc
- export CXX=mpicxx
- export FC=mpif90
- export F77=mpif77
- fi
- econf \
- --disable-rpath \
- --without-pvm \
- $(use_enable doc build-help) \
- $(use_enable nls) \
- $(use_enable nls build-localization) \
- $(use_with fftw) \
- $(use_with gui)\
- $(use_with gui javasci)\
- $(use_with hdf5) \
- $(use_with matio) \
- $(use_with umfpack) \
- $(use_with tk) \
- $(use_with xcos scicos) \
- ${myopts}
-}
-
-src_compile() {
- emake || die "emake failed"
- if use doc; then
- emake doc || die "emake failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- # install docs
- dodoc ACKNOWLEDGEMENTS CHANGES README_Unix RELEASE_NOTES \
- Readme_Visual.txt || die "failed to install docs"
-
- #install icon
- newicon icons/scilab.xpm scilab.xpm
- make_desktop_entry ${PN} "Scilab" ${PN}
-}
-
-pkg_postinst() {
- einfo "To tell Scilab about your printers, set the environment"
- einfo "variable PRINTERS in the form:"
- einfo
- einfo "PRINTERS=\"firstPrinter:secondPrinter:anotherPrinter\""
-}