aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-04 13:08:49 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-03-04 13:08:49 +0100
commit05c0b4ec3733034cb12a8e4c4121182c012db8ff (patch)
tree19f8d94ea1021a0efd769f15af299bc50c94bac2
parentsci-mathematics/flocq: drop old (diff)
downloadsci-05c0b4ec3733034cb12a8e4c4121182c012db8ff.tar.gz
sci-05c0b4ec3733034cb12a8e4c4121182c012db8ff.tar.bz2
sci-05c0b4ec3733034cb12a8e4c4121182c012db8ff.zip
sci-mathematics/gappalib-coq: version bump 1.4.6
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-mathematics/gappalib-coq/Manifest1
-rw-r--r--sci-mathematics/gappalib-coq/gappalib-coq-1.4.6.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/gappalib-coq/Manifest b/sci-mathematics/gappalib-coq/Manifest
index d3808c01f..6770e661e 100644
--- a/sci-mathematics/gappalib-coq/Manifest
+++ b/sci-mathematics/gappalib-coq/Manifest
@@ -1 +1,2 @@
DIST gappalib-coq-1.0.0.tar.gz 118901 BLAKE2B a72ae81f8003bd0e4fd58e57cd10612d5cea4657d4d1c59a17ef04075aed5de0ee836c632e904024553f912a8c52b221ed79d62377686fea5fe1c3b4982b98f5 SHA512 1aed7eafc24d82fbb3431e267ae0882560b34864f443fa95b450f465fe571cae558bc0ddf31db96477092518dd20a9870a9f8360ad8a0b3967d6f912c2bd0b67
+DIST gappalib-coq-1.4.6.tar.gz 114284 BLAKE2B 2c1b38b324786f20d7503d1c2243b95b7f8b090068563120669de37ef6cd5dc4fa479b5f3e0559372f4d1fdafa833619191c73780adad45056972108a32e1d1e SHA512 bb9c431d320d9c66998ec02ba7d459ee3f00cb7b16f89e57f3d7eb4b89cd3c9254e98e3906a8dfac31f73e5a32918ad12eaeaf7504750d3bfdce878913b745d3
diff --git a/sci-mathematics/gappalib-coq/gappalib-coq-1.4.6.ebuild b/sci-mathematics/gappalib-coq/gappalib-coq-1.4.6.ebuild
new file mode 100644
index 000000000..82b02933c
--- /dev/null
+++ b/sci-mathematics/gappalib-coq/gappalib-coq-1.4.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Allows the certificates Gappa generates to be imported by the Coq"
+HOMEPAGE="http://gappa.gforge.inria.fr/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/38386/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=sci-mathematics/gappa-1.3.2
+ >=sci-mathematics/coq-8.8
+ >=sci-mathematics/flocq-3.0
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i Remakefile.in \
+ -e "s:mkdir -p @libdir@:mkdir -p \${DESTDIR}@libdir@:g" \
+ -e "s:cp \$(OBJS) \$(MLTARGETS) @libdir@:cp \$(OBJS) \$(MLTARGETS) \${DESTDIR}@libdir@:g"
+}
+
+src_compile() {
+ ./remake || die "emake failed"
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install || die "emake install failed"
+ einstalldocs
+}