aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-24 16:34:21 +0200
committerJustin Lecher <jlec@gentoo.org>2011-06-24 16:34:21 +0200
commit0a889c1c3734c9b48b5d0cc048924f3ce3661ac2 (patch)
tree3f722d66c100c012f6d1dc792881c84daa04e327
parentSort inherit and/or USE (diff)
downloadsci-0a889c1c3734c9b48b5d0cc048924f3ce3661ac2.tar.gz
sci-0a889c1c3734c9b48b5d0cc048924f3ce3661ac2.tar.bz2
sci-0a889c1c3734c9b48b5d0cc048924f3ce3661ac2.zip
metadata.xml added
(Portage version: 2.2.0_alpha41/git/Linux x86_64, signed Manifest commit with key 70EB7916)
-rw-r--r--sci-libs/pagmo/ChangeLog8
-rw-r--r--sci-libs/pagmo/Manifest14
-rw-r--r--sci-libs/pagmo/metadata.xml12
-rw-r--r--sci-libs/pagmo/pagmo-9999.ebuild16
4 files changed, 42 insertions, 8 deletions
diff --git a/sci-libs/pagmo/ChangeLog b/sci-libs/pagmo/ChangeLog
new file mode 100644
index 000000000..ce5b5822c
--- /dev/null
+++ b/sci-libs/pagmo/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sci-libs/pagmo
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 24 Jun 2011; Justin Lecher <jlec@gentoo.org> pagmo-9999.ebuild,
+ +metadata.xml:
+ metadata.xml added
+
diff --git a/sci-libs/pagmo/Manifest b/sci-libs/pagmo/Manifest
index 0a62ed106..64a4d438e 100644
--- a/sci-libs/pagmo/Manifest
+++ b/sci-libs/pagmo/Manifest
@@ -1 +1,13 @@
-EBUILD pagmo-9999.ebuild 887 RMD160 4c9f301299d663468dfc64b13fa76c1db1c559c3 SHA1 2c608caa9a20559de1c53fb7d5bd015707e3f443 SHA256 f836edbbdaaf3072b8a0b3e5247b2f02c1be4564425a379ead3804ff9643e841
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+EBUILD pagmo-9999.ebuild 888 RMD160 0beb1b7b2f853064ccae1a58ff712ab226d6daab SHA1 3a339ba89eb27aa9d13e1bf4e8596e428d8ceba3 SHA256 af05d20d96b8039c48f7471dba1720f5d4518a29b210f9b3bf76eaba729dcf6d
+MISC ChangeLog 220 RMD160 707fdd0f6878ab8c2075be1ff4dfca736cc1a0f1 SHA1 a85cc93d71adb7ec8ffe31435ad8ea556614cea1 SHA256 76a6b77427b2be531bd2d7ab0052a3e94ed24d6cbe88e968499a426524c84185
+MISC metadata.xml 394 RMD160 c37a0df07b17132c8ade8940be56ca53dbe3e4e1 SHA1 01a3b8cc45d393e133db512d4c3e6d6c295fc50a SHA256 35e35c14539678da6e673f03918f6954b972fc8025ccb5eb4ba54cfb8ac00d72
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iEYEARECAAYFAk4EoG0ACgkQgAnW8HDreRY37gCdEUTyrJJSzcoDEljkV53YwS0N
+HlgAoJvoLfMLgRTUW74F0MqerXu49RxQ
+=9t+G
+-----END PGP SIGNATURE-----
diff --git a/sci-libs/pagmo/metadata.xml b/sci-libs/pagmo/metadata.xml
new file mode 100644
index 000000000..0bf16da57
--- /dev/null
+++ b/sci-libs/pagmo/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>sci@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="kepler">Automatically generated description for kepler</flag>
+ <flag name="nlopt">Automatically generated description for nlopt</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-libs/pagmo/pagmo-9999.ebuild b/sci-libs/pagmo/pagmo-9999.ebuild
index 8a898fc1e..87c5298fc 100644
--- a/sci-libs/pagmo/pagmo-9999.ebuild
+++ b/sci-libs/pagmo/pagmo-9999.ebuild
@@ -1,23 +1,25 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="2"
+EAPI=4
+
inherit cmake-utils git
DESCRIPTION="Parallelization engine for optimization problems"
HOMEPAGE="http://pagmo.sourceforge.net/"
-EGIT_REPO_URI="git://pagmo.git.sourceforge.net/gitroot/pagmo/pagmo"
SRC_URI=""
+EGIT_REPO_URI="git://pagmo.git.sourceforge.net/gitroot/pagmo/pagmo"
LICENSE="GPL-3"
SLOT="0"
-IUSE="gsl kepler mpi nlopt python test"
KEYWORDS="~amd64 ~x86"
+IUSE="gsl kepler mpi nlopt python test"
-RDEPEND="dev-libs/boost[mpi?,python?]
- gsl? ( sci-libs/gsl )
- nlopt? ( sci-libs/nlopt )"
+RDEPEND="
+ dev-libs/boost[mpi?,python?]
+ nlopt? ( sci-libs/nlopt )
+ gsl? ( sci-libs/gsl )"
DEPEND="${RDEPEND}"
src_configure() {