aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-06-16 11:47:52 +0200
committerJustin Lecher <jlec@gentoo.org>2013-06-16 11:47:52 +0200
commit0b84959d043574acb6d9bc2c62869c3bc237ba72 (patch)
tree68c6d4d5661b8d68dcf932bf318a1a83af14f075
parentsci-biology/tablet-bin: Version BUmp; BUmp to EAPI5 and python-r1.eclass (diff)
downloadsci-0b84959d043574acb6d9bc2c62869c3bc237ba72.tar.gz
sci-0b84959d043574acb6d9bc2c62869c3bc237ba72.tar.bz2
sci-0b84959d043574acb6d9bc2c62869c3bc237ba72.zip
sci-chemistry/chemBuild: Bump EAPI and python eclass
Package-Manager: portage-2.2.0_alpha180
-rw-r--r--sci-chemistry/chemBuild/ChangeLog6
-rw-r--r--sci-chemistry/chemBuild/chemBuild-1.0.2.ebuild33
-rw-r--r--sci-chemistry/chemBuild/files/chemBuild2
-rw-r--r--sci-chemistry/chemBuild/metadata.xml2
4 files changed, 18 insertions, 25 deletions
diff --git a/sci-chemistry/chemBuild/ChangeLog b/sci-chemistry/chemBuild/ChangeLog
index a592f6b45..7aa6b2ef5 100644
--- a/sci-chemistry/chemBuild/ChangeLog
+++ b/sci-chemistry/chemBuild/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-chemistry/chemBuild
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 16 Jun 2013; Justin Lecher <jlec@gentoo.org> chemBuild-1.0.2.ebuild,
+ files/chemBuild, metadata.xml:
+ Bump EAPI and python eclass
+
21 Sep 2012; Justin Lecher <jlec@gentoo.org> chemBuild-1.0.2.ebuild:
Needs webkit support in pyside
diff --git a/sci-chemistry/chemBuild/chemBuild-1.0.2.ebuild b/sci-chemistry/chemBuild/chemBuild-1.0.2.ebuild
index dece95eb2..3f4733f8b 100644
--- a/sci-chemistry/chemBuild/chemBuild-1.0.2.ebuild
+++ b/sci-chemistry/chemBuild/chemBuild-1.0.2.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="2"
+PYTHON_COMPAT=( python{2_6,2_7} )
-inherit python toolchain-funcs
+inherit python-single-r1 toolchain-funcs
DESCRIPTION="Graphical tool to construct chemical compound definitions for NMR"
HOMEPAGE="http://www.ccpn.ac.uk/software/chembuild"
@@ -17,7 +17,9 @@ LICENSE="|| ( CCPN LGPL-2.1 )"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
-RDEPEND="dev-python/pyside[webkit]"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="dev-python/pyside[webkit,${PYTHON_USEDEP}]"
DEPEND=""
S="${WORKDIR}"/ccpnmr/ccpnmr3.0/
@@ -28,11 +30,6 @@ S="${WORKDIR}"/ccpnmr/ccpnmr3.0/
#unbundle inchi
#parallel build
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
src_install() {
local in_path=$(python_get_sitedir)/${PN}
local _file
@@ -44,25 +41,17 @@ src_install() {
-e "s|gentoolibdir|${EPREFIX}/usr/${libdir}|g" \
-e "s|gentootk|${EPREFIX}/usr/${libdir}/tk${tkver}|g" \
-e "s|gentootcl|${EPREFIX}/usr/${libdir}/tclk${tkver}|g" \
- -e "s|gentoopython|$(PYTHON -a)|g" \
+ -e "s|gentoopython|${PYTHON}|g" \
-e "s|gentoousr|${EPREFIX}/usr|g" \
-e "s|//|/|g" \
"${FILESDIR}"/${PN} > "${ED}"/usr/bin/${PN} || die
fperms 755 /usr/bin/${PN}
- insinto ${in_path}
-
rm -rf cNg license || die
ebegin "Installing main files"
- doins -r *
+ python_moduleinto ${PN}
+ python_domodule *
+ python_optimize
eend
}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}
diff --git a/sci-chemistry/chemBuild/files/chemBuild b/sci-chemistry/chemBuild/files/chemBuild
index c6d3d31ac..308804158 100644
--- a/sci-chemistry/chemBuild/files/chemBuild
+++ b/sci-chemistry/chemBuild/files/chemBuild
@@ -1,7 +1,7 @@
#!/bin/bash
export CCPNMR_TOP_DIR=gentoo_sitedir
-export PYTHONPATH=.:${CCPNMR_TOP_DIR}/chemBuild/python
+export PYTHONPATH=${CCPNMR_TOP_DIR}/chemBuild/python
export LD_LIBRARY_PATH=gentoolibdir
export TCL_LIBRARY=gentootcl
export TK_LIBRARY=gentootk
diff --git a/sci-chemistry/chemBuild/metadata.xml b/sci-chemistry/chemBuild/metadata.xml
index d369d068f..897aa2e6b 100644
--- a/sci-chemistry/chemBuild/metadata.xml
+++ b/sci-chemistry/chemBuild/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
+ <herd>sci</herd>
</pkgmetadata>