aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-21 21:05:30 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-21 21:05:30 +0200
commit0da6329ec2ab9171b92ab9f5e36114053a3e0559 (patch)
tree578f10874b65f5016c98cea245f23197ed504e78
parentsci-misc/opennlp-tools: Add subslot operators (diff)
downloadsci-0da6329ec2ab9171b92ab9f5e36114053a3e0559.tar.gz
sci-0da6329ec2ab9171b92ab9f5e36114053a3e0559.tar.bz2
sci-0da6329ec2ab9171b92ab9f5e36114053a3e0559.zip
sci-physics/elk: Use python eclass
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-physics/elk/elk-2.1.25.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sci-physics/elk/elk-2.1.25.ebuild b/sci-physics/elk/elk-2.1.25.ebuild
index 94676a09a..e521ac861 100644
--- a/sci-physics/elk/elk-2.1.25.ebuild
+++ b/sci-physics/elk/elk-2.1.25.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit eutils flag-o-matic fortran-2 multilib toolchain-funcs
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils flag-o-matic fortran-2 multilib toolchain-funcs python-single-r1
DESCRIPTION="All-electron full-potential linearised augmented-plane wave (FP-LAPW)"
HOMEPAGE="http://elk.sourceforge.net/"
@@ -15,13 +17,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="-debug lapack libxc mpi openmp perl python test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
RDEPEND="
lapack? (
virtual/blas
virtual/lapack )
libxc? ( >=sci-libs/libxc-1.2.0-r1[fortran] )
perl? ( dev-lang/perl )
- python? ( dev-lang/python )
+ python? ( ${PYTHON_DEPS} )
mpi? ( virtual/mpi )"
DEPEND="${RDEPEND}
virtual/pkgconfig"