aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-29 13:21:17 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-29 13:21:17 +0100
commit10b429a61f236385b562b09d2890e95f2fadf9c9 (patch)
treedc82da785da5e769de9eedfa0a75ff88c92ac0d3
parentsci-chemistry/chimera-bin: add missing REQUIRED_USE="${PYTHON_REQUIRED_USE}" (diff)
downloadsci-10b429a61f236385b562b09d2890e95f2fadf9c9.tar.gz
sci-10b429a61f236385b562b09d2890e95f2fadf9c9.tar.bz2
sci-10b429a61f236385b562b09d2890e95f2fadf9c9.zip
sci-misc/jwnl: version bump 1.4_rc2, EAPI bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-misc/jwnl/Manifest3
-rw-r--r--sci-misc/jwnl/jwnl-1.3_rc3.ebuild48
-rw-r--r--sci-misc/jwnl/jwnl-1.4_rc2.ebuild48
3 files changed, 49 insertions, 50 deletions
diff --git a/sci-misc/jwnl/Manifest b/sci-misc/jwnl/Manifest
index b63c83247..6ec349e7a 100644
--- a/sci-misc/jwnl/Manifest
+++ b/sci-misc/jwnl/Manifest
@@ -1,2 +1 @@
-DIST jwnl13rc3.zip 640112 BLAKE2B ab69cc0cf848de3fed20231a8e2d12539c13c487e3538997072415270a5d03c1e998530f1b10b97161254e3e6867bbde8ed31fce6d864f03cf544f196b5038a3 SHA512 655497849698518bffb651f67fd2e40546ff5700b4ffa3fa7ee63125b4523a4720f5644e8f06266072342ee583ad5383f5e0cf01fda23bfe90419b06438ef697
-DIST jwnl13rc3_src.zip 109993 BLAKE2B f5bdb5bb87cf70aa3640273dd8ee410173d1c4be0daa06a531810f80668af655ca2a866fab9860205ba2ca9dd944ceba8bcba32f522465d0ceb5af5ddd890201 SHA512 89524c349a50fae09a8dcbc6fa9ba03227200eb389ba8903b7d3a2ca678e5bcd4c25ae20da67728dac8f563b9f535aadb6ecdd838c79961c5788148951a386e5
+DIST jwnl14-rc2.zip 1554168 BLAKE2B d73747b161f0a1183d00f8953e7317783b88d6da99d0829f9d3912862b6e6e6953265c49ed4764df2dae7703750881765fafe50455ea8ae5ce6fe56de1b3a51b SHA512 2d279803489e1259563f671efa707902e85b338851df69a73b5f863fc0b520fb85aab4ce41e2781cab8dccfb5cf8c320150f54f798022e186945584d7c5c70d9
diff --git a/sci-misc/jwnl/jwnl-1.3_rc3.ebuild b/sci-misc/jwnl/jwnl-1.3_rc3.ebuild
deleted file mode 100644
index 7abef0b58..000000000
--- a/sci-misc/jwnl/jwnl-1.3_rc3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils java-pkg-2 java-utils-2 versionator
-
-MY_P=${PN}$(delete_all_version_separators)
-
-DESCRIPTION="Java interface to WordNet dictionary data"
-HOMEPAGE="http://jwordnet.sf.net"
-SRC_URI="
- mirror://sourceforge/jwordnet/${MY_P}_src.zip
- mirror://sourceforge/jwordnet/${MY_P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-COMMON_DEP="dev-java/commons-logging"
-DEPEND=">=virtual/jdk-1.4
- app-arch/unzip
- ${COMMON_DEP}"
-RDEPEND=">=virtual/jre-1.4
- ${COMMON_DEP}"
-
-S="${WORKDIR}"
-
-src_prepare() {
- rm -v commons-logging.jar jwnl.jar || die
-}
-
-src_compile() {
- # picked up from dev-java/ant-eclipse-ecj
- ejavac -classpath "$(java-pkg_getjars commons-logging)" \
- `find net -name '*.java'` || die "ejavac failed"
- find net -name '*.class' -o -name '*.properties' | \
- xargs jar cf "${S}/${PN}.jar" || die "jar failed"
-}
-
-src_install() {
- java-pkg_dojar ${PN}.jar utilities.jar
- insinto /usr/share/${PN}
- doins create.sql database_properties.xml file_properties.xml \
- jwnl_properties.dtd jwnl_properties.xsd map_properties.xml
- dodoc changes.txt
-}
diff --git a/sci-misc/jwnl/jwnl-1.4_rc2.ebuild b/sci-misc/jwnl/jwnl-1.4_rc2.ebuild
new file mode 100644
index 000000000..6a25eede5
--- /dev/null
+++ b/sci-misc/jwnl/jwnl-1.4_rc2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2 java-utils-2
+
+MY_P=${PN}${PV//.}
+
+DESCRIPTION="Java interface to WordNet dictionary data"
+HOMEPAGE="https://sourceforge.net/projects/jwordnet/"
+SRC_URI="mirror://sourceforge/jwordnet/${MY_P//_rc/-rc}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEP="
+ dev-java/commons-logging:0
+ dev-java/junit:4
+"
+DEPEND=">=virtual/jdk-1.7
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.7
+ ${COMMON_DEP}"
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MY_P//_rc/-rc}"
+
+src_prepare() {
+ rm jwnl.jar lib/commons-logging.jar lib/junit-4.1.jar || die
+ default
+}
+
+src_compile() {
+ # picked up from dev-java/ant-eclipse-ecj
+ ejavac -classpath "$(java-pkg_getjars commons-logging):$(java-pkg_getjars junit:4)" \
+ `find -name '*.java'` || die "ejavac failed"
+ find -name '*.class' -o -name '*.properties' | \
+ xargs jar cf "${S}/${PN}.jar" || die "jar failed"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ insinto /usr/share/${PN}
+ doins -r sql config/*
+ dodoc changes.txt
+}