aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-08-12 16:50:20 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-08-12 16:50:20 +0200
commit117e68964983a002abe4bd0917dd4545e806a07c (patch)
tree8254b144626377c17989d3be72eeeb187166872b
parentdev-python/nbconvert: Initial ebuild (diff)
downloadsci-117e68964983a002abe4bd0917dd4545e806a07c.tar.gz
sci-117e68964983a002abe4bd0917dd4545e806a07c.tar.bz2
sci-117e68964983a002abe4bd0917dd4545e806a07c.zip
dev-python/jupyter_console: Initial ebuild
Package-Manager: portage-2.2.20
-rw-r--r--dev-python/jupyter_console/ChangeLog10
-rw-r--r--dev-python/jupyter_console/Manifest1
l---------dev-python/jupyter_console/jupyter_console-4.0.0.ebuild1
-rw-r--r--dev-python/jupyter_console/jupyter_console-9999.ebuild31
-rw-r--r--dev-python/jupyter_console/metadata.xml9
5 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/jupyter_console/ChangeLog b/dev-python/jupyter_console/ChangeLog
new file mode 100644
index 000000000..aca91f96c
--- /dev/null
+++ b/dev-python/jupyter_console/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/jupyter_console
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*jupyter_console-4.0.0 (12 Aug 2015)
+*jupyter_console-9999 (12 Aug 2015)
+
+ 12 Aug 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +jupyter_console-4.0.0.ebuild, +jupyter_console-9999.ebuild, +metadata.xml:
+ dev-python/jupyter_console: Initial ebuild
diff --git a/dev-python/jupyter_console/Manifest b/dev-python/jupyter_console/Manifest
new file mode 100644
index 000000000..b66f749c8
--- /dev/null
+++ b/dev-python/jupyter_console/Manifest
@@ -0,0 +1 @@
+DIST jupyter_console-4.0.0.tar.gz 21416 SHA256 21d940dda6da3fce56f69c9fe92a125990c4a5436280ba66f1ad47bda63ebf76 SHA512 b21f372d965262265664d4ca91e6eb2ad9a24afd58caa25083f32dc04fa943ef3d15ea2be2793d90d1b1c906a9be9324de0fc513d4942d0f9d334fed757448d0 WHIRLPOOL 4f4c278ebef2243706951c71f3b970c1b7bf389f4ddcfdc76874ce17ea10961f03ff1a95368385bcf670d1b2d27c087204439c8dbc724124db6f7395a3f04657
diff --git a/dev-python/jupyter_console/jupyter_console-4.0.0.ebuild b/dev-python/jupyter_console/jupyter_console-4.0.0.ebuild
new file mode 120000
index 000000000..38c6bbe4d
--- /dev/null
+++ b/dev-python/jupyter_console/jupyter_console-4.0.0.ebuild
@@ -0,0 +1 @@
+jupyter_console-9999.ebuild \ No newline at end of file
diff --git a/dev-python/jupyter_console/jupyter_console-9999.ebuild b/dev-python/jupyter_console/jupyter_console-9999.ebuild
new file mode 100644
index 000000000..dcfd95ebb
--- /dev/null
+++ b/dev-python/jupyter_console/jupyter_console-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="jupyter_console"
+
+DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
+HOMEPAGE="http://jupyter.org"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jupyter/${MY_PN}.git git://github.com/jupyter/${MY_PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"
diff --git a/dev-python/jupyter_console/metadata.xml b/dev-python/jupyter_console/metadata.xml
new file mode 100644
index 000000000..b3fa0d4bd
--- /dev/null
+++ b/dev-python/jupyter_console/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ A terminal-based console frontend for Jupyter kernels.
+ This code is based on the single-process IPython terminal.
+ </longdescription>
+</pkgmetadata>