aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@gentoo.org>2010-02-28 12:02:48 +0100
committerJustin Lecher (jlec) <jlec@gentoo.org>2010-02-28 12:02:48 +0100
commit12ef7b0b3f7da95c76caa6f56f7aa931e9a4667f (patch)
tree1d0b46f7d28b832567a44fdab4d0f66ef053d52b
parentInCvs (diff)
downloadsci-12ef7b0b3f7da95c76caa6f56f7aa931e9a4667f.tar.gz
sci-12ef7b0b3f7da95c76caa6f56f7aa931e9a4667f.tar.bz2
sci-12ef7b0b3f7da95c76caa6f56f7aa931e9a4667f.zip
QA: respecting FLAGS, metadata.xml fixed
(Portage version: 2.2_rc63/git/Linux x86_64) (Signed Manifest commit)
-rw-r--r--sci-libs/cdd+/Manifest14
-rw-r--r--sci-libs/cdd+/cdd+-077a.ebuild21
-rw-r--r--sci-libs/cdd+/metadata.xml2
3 files changed, 26 insertions, 11 deletions
diff --git a/sci-libs/cdd+/Manifest b/sci-libs/cdd+/Manifest
index e9324c7aa..c0419eb4a 100644
--- a/sci-libs/cdd+/Manifest
+++ b/sci-libs/cdd+/Manifest
@@ -1,6 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
AUX cdd+-077a.patch 2106 RMD160 8177f7cd9b573382bcf5ee7437b54dc8286ff4e2 SHA1 f4ff7776e64e911a3f96a6e041010e9c2cce737b SHA256 5e1163bed2ede64f06fc5037a2763c12380478e85579bbb96cb24ce151d05d12
AUX makefile.patch 1141 RMD160 68015b2d4aabe459c5e30f4c4875a880b52c047c SHA1 995aa2688079068162a117e413b59d975492b724 SHA256 8a97bc1fc44397dfab71064807f2add136a30477018087a7ad648c54c1d839ab
DIST cdd+-077a.tar.gz 186771 RMD160 059f9863dbaccb8facb4362ab8193b0156e1bdc0 SHA1 6e9a1ecd3d9bd3c4211dc252bfbb3aa0e900f9e3 SHA256 bace5c6c62fc48938b04a7b80fc55935e1bfe56cfb0b80f803842173a40ad616
-EBUILD cdd+-077a.ebuild 640 RMD160 759b86119a26f99e5c2b4ad8555375b5c135c263 SHA1 c0d5b1dce541f7406bbd312e649aeab267a6d683 SHA256 813bed3a5d009feaeaba39f51daf78ea708f3fe181ea08fbee297946e0277402
+EBUILD cdd+-077a.ebuild 836 RMD160 7de8a38729841c2232bcf5555ade33d5d372d7ae SHA1 213bd0630f0ea6864f0b3dbd72ac56d5cfc6e096 SHA256 ebb0fde57de0d289ab37453902c49f2485677808d1bb617674bd29c2bc709f40
MISC ChangeLog 393 RMD160 fa5572a0e8e7e7dac1dc43983b901e57145050bd SHA1 c4e9d652ee253947d965366f54ddcabd64e9a4ab SHA256 7fa18397e089ba4bc390cc4542c764d4b605e949a4afed448f5ff0066fbce904
-MISC metadata.xml 541 RMD160 7c3a8db628a43679c88f8acce7ae3b04d4800c8b SHA1 89aee4e72517133785f1caf09d197be8006ee22e SHA256 4de4e7f93dbea18c079634d1bad9b4ce93f8a61cb4233bb90e220476d99aa987
+MISC metadata.xml 544 RMD160 5628f4410f29a7e656d6abf36f54a641d3ba2705 SHA1 8c8e90ae1cfd590edfd4a2301d6314d41c3c02ee SHA256 6804c6d79bcc3863d414ffc9987753db97d06bb5de52288c182d7c627ac1906d
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.14 (GNU/Linux)
+
+iEYEARECAAYFAkuKTVgACgkQgAnW8HDreRZSLgCdFkWp4UCc8eXTXhAN53xrA1R/
+YCcAn0nFrsJklWEK+UpeQ1o8OWAnkz7j
+=MO+r
+-----END PGP SIGNATURE-----
diff --git a/sci-libs/cdd+/cdd+-077a.ebuild b/sci-libs/cdd+/cdd+-077a.ebuild
index eb4845850..02064cdc8 100644
--- a/sci-libs/cdd+/cdd+-077a.ebuild
+++ b/sci-libs/cdd+/cdd+-077a.ebuild
@@ -2,18 +2,17 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI="3"
+
+inherit eutils toolchain-funcs
-inherit eutils
DESCRIPTION="Another implementation of the double description method"
HOMEPAGE="http://www.ifor.math.ethz.ch/~fukuda/cdd_home/"
SRC_URI="ftp://ftp.ifor.math.ethz.ch/pub/fukuda/cdd/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="~x86 ~amd64"
-
IUSE=""
DEPEND="dev-libs/gmp"
@@ -25,11 +24,17 @@ src_prepare() {
}
src_compile() {
- emake all || die "emake failed"
+ export LDFLAGS="${LDFLAGS}"
+ export CFLAGS="${CFLAGS}"
+ emake \
+ CC="$(tc-getCC)" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ GMPLIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ GMPINCLUDE="${EPREFIX}/usr/include" \
+ all || die
+
}
src_install() {
- dobin cddf+
- dobin cddr+
- dolib cddio.o
+ dobin cddr+ cddf+ || die
}
diff --git a/sci-libs/cdd+/metadata.xml b/sci-libs/cdd+/metadata.xml
index 45ce8c6c4..00596216d 100644
--- a/sci-libs/cdd+/metadata.xml
+++ b/sci-libs/cdd+/metadata.xml
@@ -5,6 +5,6 @@
<longdescription>
The program cdd+ is a C++ implementation of the Double Description Method of Motzkin et al. for generating all
vertices (i.e. extreme points) and extreme rays of a general convex polyhedron in R^d given by a system of linear
- inequalities: P = { x : A x <= b } where A is an m x d real matrix and b is a real m dimensional vector.
+ inequalities: P = { x : A x &lt;= b } where A is an m x d real matrix and b is a real m dimensional vector.
</longdescription>
</pkgmetadata>