aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Kerr <cjk34@cam.ac.uk>2013-06-17 23:04:43 +0100
committerChris Kerr <cjk34@cam.ac.uk>2013-06-17 23:04:43 +0100
commit141c79b386269291586b9ec2187f4786963e6e72 (patch)
tree4015b43189fe67f0564969c1044abb7ff357a229
parentChanged patch format to see if this works better (diff)
downloadsci-141c79b386269291586b9ec2187f4786963e6e72.tar.gz
sci-141c79b386269291586b9ec2187f4786963e6e72.tar.bz2
sci-141c79b386269291586b9ec2187f4786963e6e72.zip
Copying diffs from the terminal stripped out tabs, causing them to fail
Try this one...
-rw-r--r--sys-cluster/htcondor/files/fix_sandbox_violations-8.0.0.patch34
1 files changed, 17 insertions, 17 deletions
diff --git a/sys-cluster/htcondor/files/fix_sandbox_violations-8.0.0.patch b/sys-cluster/htcondor/files/fix_sandbox_violations-8.0.0.patch
index 371052dbe..352516103 100644
--- a/sys-cluster/htcondor/files/fix_sandbox_violations-8.0.0.patch
+++ b/sys-cluster/htcondor/files/fix_sandbox_violations-8.0.0.patch
@@ -1,5 +1,5 @@
---- a/src/condor_scripts/CMakeLists.txt 2013-06-17 21:20:57.968455000 +0100
-+++ b/src/condor_scripts/CMakeLists.txt 2013-06-17 21:23:15.039802000 +0100
+--- src/condor_scripts/CMakeLists.txt.orig 2013-06-17 23:02:02.815939000 +0100
++++ src/condor_scripts/CMakeLists.txt 2013-06-17 23:02:34.476727000 +0100
@@ -27,9 +27,9 @@
install ( FILES condor_configure DESTINATION ${C_SBIN} PERMISSIONS ${CONDOR_SCRIPT_PERMS} )
install ( FILES condor_configure DESTINATION ${C_SBIN} RENAME condor_install PERMISSIONS ${CONDOR_SCRIPT_PERMS} )
@@ -12,23 +12,23 @@
+ install ( CODE "EXECUTE_PROCESS(COMMAND ${CMAKE_COMMAND} -E create_symlink ./sbin/condor_configure \$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/condor_configure)" )
endif(WANT_FULL_DEPLOYMENT)
- install ( FILES condor_ssh sshd.sh DESTINATION ${C_LIBEXEC} PERMISSIONS ${CONDOR_SCRIPT_PERMS} )
---- a/src/condor_tools/CMakeLists.txt 2013-06-17 21:44:18.391088000 +0100
-+++ b/src/condor_tools/CMakeLists.txt 2013-06-17 21:46:09.950286000 +0100
+ install ( FILES condor_ssh sshd.sh DESTINATION ${C_LIBEXEC} PERMISSIONS ${CONDOR_SCRIPT_PERMS} )
+--- src/condor_tools/CMakeLists.txt.orig 2013-06-17 22:50:20.459572000 +0100
++++ src/condor_tools/CMakeLists.txt 2013-06-17 22:52:59.841733000 +0100
@@ -102,13 +102,13 @@
if ( LINUX AND NOT CONDOR_PACKAGE_BUILD )
- set( SRC_DIR ${CMAKE_SOURCE_DIR} )
- set( BIN_DIR ${CMAKE_BINARY_DIR} )
-- install( CODE "execute_process(COMMAND mkdir -p ${CMAKE_INSTALL_PREFIX}/lib/condor)" )
-+ install( CODE "execute_process(COMMAND mkdir -p $ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/condor)" )
- install( CODE "execute_process(COMMAND ${SRC_DIR}/src/condor_scripts/print-libs ${BIN_DIR}/src/condor_tools/condor_version ${SRC_DIR}/src/condor_scripts/syslib-patterns
-- COMMAND xargs -isrc cp src ${CMAKE_INSTALL_PREFIX}/lib/condor
-+ COMMAND xargs -isrc cp src $ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/condor
- )" )
- # This is required for opensuse, where the system's libssl and
- # libcrypto files don't have owner write permission.
-- install( CODE "execute_process(COMMAND chmod -R u+w ${CMAKE_INSTALL_PREFIX}/lib/condor/)" )
-+ install( CODE "execute_process(COMMAND chmod -R u+w $ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/condor/)" )
+ set( SRC_DIR ${CMAKE_SOURCE_DIR} )
+ set( BIN_DIR ${CMAKE_BINARY_DIR} )
+- install( CODE "execute_process(COMMAND mkdir -p ${CMAKE_INSTALL_PREFIX}/lib/condor)" )
++ install( CODE "execute_process(COMMAND mkdir -p $ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/condor)" )
+ install( CODE "execute_process(COMMAND ${SRC_DIR}/src/condor_scripts/print-libs ${BIN_DIR}/src/condor_tools/condor_version ${SRC_DIR}/src/condor_scripts/syslib-patterns
+- COMMAND xargs -isrc cp src ${CMAKE_INSTALL_PREFIX}/lib/condor
++ COMMAND xargs -isrc cp src $ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/condor
+ )" )
+ # This is required for opensuse, where the system's libssl and
+ # libcrypto files don't have owner write permission.
+- install( CODE "execute_process(COMMAND chmod -R u+w ${CMAKE_INSTALL_PREFIX}/lib/condor/)" )
++ install( CODE "execute_process(COMMAND chmod -R u+w $ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/lib/condor/)" )
endif()
############################################################